Warehouse for SailfishOS

Rating: 
4.77778
Your rating: None Average: 4.8 (90 votes)

BETA. This application is still under active development. 

Warehouse is a native client for OpenRepos.net
Browse and install applications, enable repositories.

Just download and tap to install.

If warehouse does not start after upgrade, uninstall warehouse, and install latest version.

TMO support thread is open for discussions: http://talk.maemo.org/showthread.php?t=91574

Screenshots: 
Application versions: 
AttachmentSizeDate
harbour-warehouse-0.3-22.armv7hl.rpm95.04 KB18/09/2014 - 00:18
harbour-warehouse-0.3-28.armv7hl.rpm95.02 KB07/10/2014 - 00:48
harbour-warehouse-0.3-29.armv7hl.rpm94.65 KB24/10/2014 - 13:29
harbour-warehouse-0.3-30.armv7hl.rpm94.51 KB22/04/2015 - 01:03
Changelog: 

Version v0.30-30

  • General performance improvements

Version v0.3-29

  • Qt5.2. js fix.

Version v0.3-28

  • Performance regression fixed

Version v0.3-27

  • Extra transaction info added

Version v0.3-26

  • Faster repositories updates check: only openrepos
  • Application manage UI updates

Version v0.3-25

  • Hide non-openrepos updates
  • Fix categories preload
  • Check for updates at application page

Version v0.3-22

  • Search field autofocus

Version v0.3-21

  • Single repository refresh option added at profile page

Version v0.3-20

  • Warehouse Installer compatibility

Version v0.3-18

  • Basic polkit auth policy added
  • Application changelog shown
  • Fast single-repo refresh
  • Fast repository disabling

Version v0.2-16

  • Emergency fix for category API change.

Comments

vevgeniev's picture

Thanks, I'll rebuilt the package with a longer name.

xmlich02's picture

Hi, can you provide support for JollaTablet? i.e. i486 architecture

basil's picture

I cannot build&test since my tablet hasn't been delivered. You may find custom build for i486 here: https://openrepos.net/content/abranson/warehouse-jolla-tablet

Maledictus's picture

Thx for the application but today all my repos failed durin update with  status: repos not available, and Details: cannot write file /var/tmp/***/repodata/repomd.xml

basil's picture

Warehouse does not directly uses those files, but system package manager PackageKit does. You should probably check if you have free space available, or check health status of your btrfs file system.

Skillmon's picture

I have a problem with warehouse. Today it told me something like: "opening self-update-window"

After that, it seemed like nothing had changed but many icons weren't loaded. After restarting warehouse the icons are loaded properly but all my enabled repositories are gone. I am able to add new ones but the old ones are gone. When I run "ssu lr" it shows only the ones I added afterwards. No disabled repos or stuff like that.

basil's picture

The banner was "enabling self-update channel". And it seems like ssu has resets its config (or custom user settings) for some reason.

Skillmon's picture

So the only solution I have is manually adding every repo I had?

In addition I have a feature request (not that much of a new request): There was the request of adding the possibility of commenting and rating from within Warehouse. If it's not on your priority list, perhaps adding the possibility of visiting the corresponding page on openrepos.net will be an easy to implement fix.

Regards and thanks for the fast reply

Skillmon

Skillmon's picture

Just found out, that other configurations also went into nirvana. E.g. the location settings for the weather app, haven't found others yet, but perhaps this is just a matter of time.

I have another thing to complain about. The full list of currently installed aps from Warehouse doesn't work (well it starts to show them, but always crashes/stops upon that task).

Regards

Skillmon

basil's picture

Building app list function is not optimized. Do not force close application, wait for response, it will be completed.

mlwn's picture

Are there any plans to enable rating and commenting from within warehouse? Without having to visit openrepos.net from browser?
thanks

cocovina's picture

I installed Sailfish on Nexus 5 and updated to 2.0.0.10. I want to use Warehouse, but I see this after first run or when checking updates. can you help me? I tried some solutions posted to TJC, but no effect.

WH SSL Problem

 

basil's picture

Your device has invalid date. Check and update your date/time settings.

cocovina's picture

You're right - of course. How could I overlooked this? :o

Thank you!!!

erlen's picture

Hello, since January i will say, every time I install or update a program with warehouse, it is slow during the download or during the installation many time sailfish propose to wait or turn of the application. Does anyone have the problem or have an idea how to fix it ?
Thanks

basil's picture

This is known issue. Fix is under development.

V10lator's picture

Feature request: In case some dependencie can't be found while installing a package search at all openrepos repos (the ones that are disabled at the client) and if it's found: Ask the user to enable the missing repo.

//EDIT: This will most likely need some API from openrepos.net as temporary adding and removing repos might be way to slow client side.

basil's picture

This will not be implement as this is major security issue: hijack package by major version via enabling repository. One of future updates will disable all publisher repositories as main source of applicationa, and every application will be in self-contained repository: with dependencies automatically detected(packages listed and uploaded by same publisher, or manually selected by the publisher.

V10lator's picture

While you got a point here that's the reason I said "Ask the user to enable the missing repo." - So the user is still responsible for the enabled repos.
Anyhow, seems like you alredy have a better solution in the pipeline. Thanks for the info. :)
Just one last question: How will your solution handle duplicates. Let's say package A from repo X has library C from repo Y as a dependency. Now package B from repo Z has has library C as a dependency, too, but it wants it from repo W. Now the user wants to install A and B, with what library C will he end up? The one installed first, the one with the highest version number (what if both are equal - what if package A explicy says it wants a lower version), ...? Also what happens if library C gets updated in Y while A from X needs a special version (so after the update there's a version missmatch) ?

basil's picture

Default(automatic) dependencies will be filled based on package dependencies list (from deb/rpm), if any of those packages are preset at publisher own repository. After that, you can manually cherry-pick any package to be pulled from any other repository to your application repository.
If you have multiple application depending on same library, which is provided by different repositories, it's package manager job to resolve conflicts and finding apropriate versions.

aldo's picture

Hi!

I have the same problem Manankanchu has, but "pkcon refresh" return anything. Everything seems to work well but enabling some repos, including this one.

 

Manankanchu's picture

Since several days Warehouse lost connection to repositories ...

Says on "enable repository":
Status: repo-not-found

I've uninstalled Warehouse and reinstalled via Browser, but problem persists ...

Ideas welcome !

basil's picture

Under this message there is a URL of repository, that cannot be not found. It may not be associated with warehouse. Warehouse act like proxy for PackageKit and show all system errors.

Manankanchu's picture

It happens now for all repositories ...

Below it says:
Extra details:

But no link ...

basil's picture

Run 'pkcon refresh' or if you have zypper installed 'zypper ref' to see what repository cases this. Then you need disable/remove that repository, or fix your jolla account/releaes if it is releated to one of the system repositories.

Manankanchu's picture

Fixed my basic problem so now "pkcon refresh" does not return any error.

I can enable some repos like DrYak, Schturman, anig, mkiol

I cannot enable repos like coderus, basil, vasvlad, korppi

basil's picture

This happens because you already have added them earlier, but manually disabled them before(prior to) update. 'ssu lr' command will list them as disabled. Read the following discussion .

Manankanchu's picture

That did the job -  I disabled repos in Warehouse (not in CLI) before update, that's correct. Fixed it using script from Coderus ! Thanks heaps, back on Warehouse again  !!!

Manankanchu's picture

pkcon refresh finishes with "Authentication failed (is SSU set up correctly)" ... no clue what that means, will search further tomorrow, seems to be some basic issue ...

Thanks a lot for your fast help !!

Nik4u's picture

Please add login, comment, rate app

Pages