MeeRun Sports Tracker

Your rating: None Average: 4.9 (75 votes)

MeeRun is a GPS Sports Tracking application which provides a user-friendly and powerful way to manage your sport activities. It has a strong focus on accuracy and usability but also provides innovative and unique features like the facility to replay a session, a detailed elevation profile and an integrated lock screen.

Main features:file format
- For jogging, biking, hiking, skating, sailing, driving, flying and more
- Real-time distance, time, lap, speed, pace, heart rate, elevation, calories, ...
- Audio feedback (English and German): regular and manual updates
- Map: OpenStreetMap, Nokia maps
- Heart Rate Monitoring (HRM)
- Manual and auto-pauses
- Online + offline filter
- Lock screen (with run info and swipe-to-unlock)
- Split table
- Elevation profile (distance, grade, gain/loss, ...)
- Statistics and charts (speed, intervals, elevation, heart rate, HR zones, ...)
- Interactive review with timeline
- GPX import/export
- Minimal resource usage
- Light-weight and intuitive UI
- No ads, no account required, no registration needed, no ad!

Heart Rate Monitoring

To be able to monitor your heart rate, you will need a Bluetooth (non-smart) device (Zephy HxM BT, Polar Wearlink+, ...). Sports Tracker devices have been reported to work but are not officially supported

Application versions: 
File harbour-meerun-1.7.90-1.armv7hl.rpm4.24 MB14/05/2014 - 19:10
File harbour-meerun-1.8.3-1.armv7hl.rpm4.26 MB21/07/2014 - 02:47
File harbour-meerun-1.8.4-1.armv7hl.rpm4.27 MB22/07/2014 - 23:44
File harbour-meerun-2.2.0-1.armv7hl.rpm2.49 MB24/12/2014 - 00:33
File harbour-meerun-2.2.1-1.armv7hl.rpm3.83 MB24/12/2014 - 01:30
File harbour-meerun-2.2.2-1.armv7hl.rpm3.83 MB24/12/2014 - 02:27
File harbour-meerun-2.3.0-1.armv7hl.rpm3.89 MB23/03/2015 - 21:28
File harbour-meerun-2.3.1-1.armv7hl.rpm4.05 MB30/03/2015 - 14:51
File harbour-meerun-2.3.2-1.armv7hl.rpm4.05 MB01/04/2015 - 14:26
File harbour-meerun-2.3.4-1.armv7hl.rpm4.05 MB26/04/2015 - 02:23
File harbour-meerun-2.4.4-1.armv7hl.rpm4.1 MB02/06/2015 - 04:05
File harbour-meerun-3.3.14-1.armv7hl.rpm7.5 MB13/06/2016 - 00:33
File harbour-meerun-3.3.15-1.armv7hl.rpm7.47 MB13/06/2016 - 23:14

- Fixed package issue


tonyk's picture

I think it would be more important to automatically upload the workout to heiaheia/sportstracker/endomondo etc. I use both heiaheia and sportstracker and I just upload the exported data there now. At least heiaheia has a good api for it.


strahl's picture

@aifargotamenik - I see the same, after the auto-pause there is a trkpt with lat=lon=0 - I made a simple script to remove until the fix is ready - just run this in a bash shell with xmlstarlet installed on your system :) stefan

for f in *.gpx
xmlstarlet ed -N gpx= -d gpx:trkpt[@lat=0]" < $f > ${f%%.*}_post.gpx

rolfa's picture

Habe gerade gespendet und hoffe gerne auf Updates dieser App!

bwalter's picture

Danke! Updates werden auf jeden Fall bald ankommen!

aifargotamenik's picture

It looks like I debugged your issue. I compared Sailfish and N9 GPX files and in Sailfish version the following appears from time to time:
            <trkpt lat="0" lon="0">

After I removed all occurrences it looks OK in Garmin.

bwalter's picture

Thanks for the report! It will be fixed in next release.

aifargotamenik's picture

I also got distance below zero (minus kilometres). There can be big speed on one of my tracks, because of pause that I forgot to turn off, but "-" for kilometres is definitely wrong. I did a test:

1. Exported GPX from MeeRun on Sailfish

2. Imported the track to MeeRun on N9 (looked OK)

3. Exported the track back to GPX on MeeRun on N9

4. Imported the GPX from point 3.  in Garmin Connect

and it looks OK now.

Hope this helps.

aifargotamenik's picture

Just imported GPX to Garmin Connect and there is total mess with

Avg. speed:169,147.7 km/h

Avg. Moving Speed:172,668.4 km/h

Max. speed:2,995,410.0 km/h

I don't remember having these kind of problems in N9 version. It looks OK on the map.

Eccenux's picture

Have some problems in Sailfish 1.0.7:

  1. The cover is always empty.
  2. Lock screen (cover?) settings are not persistent. Steps:
    1. Go to Settings -> Display.
    2. Change 1st line to e.g. Duration.
    3. Swpie right.
    4. Go back to Display.
    5. 1st line is again default.
  3. It's not possible to enable audio feedback. It works when I press Test in language selection, but I cannot enable it when starting new training.

I would be glad to donate if you could fix that :-).

bwalter's picture

Sure, we will try our best without condition :)

AnttiT's picture

I agree with the others, it's a great app.

I was using it abroad some time ago though, and noticed it's really annoying when the phone is offline: the app requests for Internet access all the time, which opens up the Internet access selection menu even when the app is minimised. It makes the usage of the whole phone really cumbersome.

matimilko's picture

After some using meerunI've found some missings:

On my meerun sound doesent work and I dont have any signs or anything on Tab view?

Any sugestions?



ejvdweij's picture

I've been trying to delete the 'Laufen in Wien' demo. I deleted from the UI and also deleted manually from the ~/.Meerun folder and tried many times. But the demo is always re-generated when starting the app. Is there a way to prevent that?

ejvdweij's picture

Well, I found some work-around: In the terminal I copied one of my own exercises to the set of demo.* files (demo.meerun, demo.mrf, demo.mrr). Now 'Laufen in Wien' doesn't come back anymore.

samikk's picture

Thank you very much for making this to Sailfish!

Would it be possible to get pebble integration also?

Maybe with SkippingStones?

matimilko's picture

Thak You!

I've shortly tested it yesterday on skating. 

Tracking is excellent!

On my Tab view is nothing.



You have PayPal to donate you for a beer or two? (sorry, I've found a button!)

aifargotamenik's picture

I've been using the app extensively on N9 (btw, I didn't find OSM license info on N9 version, am I missing something ?). As for Sailfish OS
1. It took me some time to find out how to get the chart screen (e.g. for elevation) without returning to the main screen - it doesn't fit to Sailfish OS I think, one has to click on the map when dragging.
2. Are downloaded elevation data saved to phone or do I need to have Internet access every time I choose this option? Where they are downloaded from?
3. I agree there are too much items in the pulley. For me global settings should be accessible from the main screen only
4. How about new training option being accessible from pulley, but the bottom side instead of the top one? I think that would be neat
5. That's weird that OSM copyright info is accessible from Privacy Policy
6. I could not find OSM on the map list, but when MapQuest is selected it looks like OSM
7. Really strange map scrolling (two fingers required - with one finger zoom is changing plus the map becomes transparent)
8. Active cover can display current training info or switch between old trainings summaries when not in training

trentjnr's picture

OK, took it for a run this morning and everything works super! My only problem is importing the gpx files into Runkeeper or Garmin Connect. After I exported the activity I tried to import it from RunKeeper...the page crashes everytime when trying to upload the file. I think this might have something to do with the file formatting?
I manage to upload to Garmin Connect but when I view the activity the values are completely different than the ones MeeRun show. Eg, in MeeRun my 3.32km run becomes 18.500km!!! Avg speed of 13km/h becomes 73.300km/h. Only the duration and the recorded gps track show the right values.

Any idea what's going on? Again, in MeeRun itself everything works fine! 

aifargotamenik's picture

Hello trentjnr,

     check whether there are the following entries in your GPX file:
            <trkpt lat="0" lon="0">

and remove them. Hope this will help you.

Jordi's picture

Thanks for bringing this great app on our Jolla.

Some minor tweaks would be welcome (draging map mainly).

Meerun is impressive, the accuracy of the recorded track (length, etc) is the best seen so far!

2cv's picture

Thanks for this app, been waiting it.. Tried it today, otherwise worked fine but during training the "stop"-button doesn't work (play and pause worked fine), so I couldn't stop and save my training..

bwalter's picture

It is actually not a bug but will definitely require some visual improvements: the button is not supposed to be pressed but you should swipe it up (it is done to avoid accidental stops).

sebix's picture

Oh yes, that definitely needs improvement. There's no tutorial, there is no documentation to look for instructions on how to save the track, just a hopping 'stop'-button. I searched quite a while in the internet to find this advice. The rest of the app is great, if you know how to save the tracks.

2cv's picture

Okay, actually I accidently did swipe the stop-button earlier, but I didn't move it up enough. Just thouhgt that there's a bug or something else. Thank's for advice and for a great app.

atska97's picture

Useless. Not find Nokia maps.

bwalter's picture

Thanks for the feedback! For consistency with the Sailfish Application UI, I agree that the pulley menu should be improved (less items, better ordering, ...). Regarding the button, it is still difficult to say... And as "making it an option" is *not* an option, we will wait for more feedback before deciding to remove it or not.

Sanpo's picture

Thank You, I've been waiting for this.

How about bluetooth 4.0 HRM? Didn't work, as I try... Is there gonna be support in future?

I will donate, when it works ;)

I agree with nodevel. And the point of Sailfish Os is less buttons please. Pulley menu is great and swipe. 

Disagree with trentjnr, clicking buttons sucks...!

bwalter's picture

Wow, that's a very direct request. I will just answer right now and without condition ;) As far as I know, even if the hardware does support BT 4.0,  the API is not available yet. If you know any solution (ideally with examples), we will be happy to integrate it to the app (it is already prepared for it). Otherwise, we will have to wait for a new SDK release which will hopefully support BT 4.0.

trentjnr's picture

Registered on openrepos just to comment here.
THANK YOU for bringing this over to Jolla, I had bought it before for N9.

This seems a much improved version over the N9 app just looking at the features but I haven't tested it yet.
Few things I would like to add, some settings are not taking effect (like naytsyrhc said), for example settings>display changing lock screen parameters, nothing happens, only shows Distance.

I disagree with nodevel about the removal of the New Training button. I find it much easier just to click there than going to the pull down menu. And remember, this is an app to use outdoors and we are often (always in my case) very sweaty. Clicking in a button is MUCH easier than to go to the menu when we are sweaty. On MeeRun for N9 I often have problems to make an activity Stop because that button requires a small slide up and with sweaty hands it's a challenge very often.

Many thanks again!!!


nodevel's picture

Thank you, I've been waiting for this kind of app (even though Rena works quite well).

After a short while of using it I noticed some UI quirks:

  • You have the menu order wrong - items in PullDownMenu need to be sorted (by importance) from bottom to top, as the bottom item is the first to be seen when you pull the menu down
  • Maximum recommended number of items in a PullDownMenu (or PushUpMenu), according to Jolla, is 4. See the Common Pitfalls in Sailfish Application Development.
  • Instead of the black 'Loading...' pop-up, it might be better to use some native way of displaying such things - either BusyIndicator on the new page or maybe even the RemorseItem
  • The 'New Training' button should be removed (again, according to guidelines) - it's already in the menu.
  • Try opening the PullDownMenu, draging the app back without selecting any item and draging further - really weird thing happens.
  • When one selects 'New Training' and pushes the dialogue forward, nothing happens (and again, there a button, which is not recommended).
  • Try going into Settings->Audio Feedback->Regular Updates. Change Distance Interval setting on that page and go back. Then go again to Regular Updates. You will see that the option is now disabled. Going back again will confirm it and disable it even though you did not choose that option.

I have few suggestions as well:

  • Combine the 'Privacy Policy' and 'About' to decrease the number of items in the menu (or maybe even move it into PullDownMenu in Settings? but that might be too radical)
  • Show the 'Settings' and 'About' options on the main page only.


Other than that, it is already incredibly useful.