MeeRun Sports Tracker

Your rating: None Average: 4.9 (75 votes)

MeeRun is a GPS Sports Tracking application which provides a user-friendly and powerful way to manage your sport activities. It has a strong focus on accuracy and usability but also provides innovative and unique features like the facility to replay a session, a detailed elevation profile and an integrated lock screen.

Main features:file format
- For jogging, biking, hiking, skating, sailing, driving, flying and more
- Real-time distance, time, lap, speed, pace, heart rate, elevation, calories, ...
- Audio feedback (English and German): regular and manual updates
- Map: OpenStreetMap, Nokia maps
- Heart Rate Monitoring (HRM)
- Manual and auto-pauses
- Online + offline filter
- Lock screen (with run info and swipe-to-unlock)
- Split table
- Elevation profile (distance, grade, gain/loss, ...)
- Statistics and charts (speed, intervals, elevation, heart rate, HR zones, ...)
- Interactive review with timeline
- GPX import/export
- Minimal resource usage
- Light-weight and intuitive UI
- No ads, no account required, no registration needed, no ad!

Heart Rate Monitoring

To be able to monitor your heart rate, you will need a Bluetooth (non-smart) device (Zephy HxM BT, Polar Wearlink+, ...). Sports Tracker devices have been reported to work but are not officially supported

Application versions: 
File harbour-meerun-1.7.90-1.armv7hl.rpm4.24 MB14/05/2014 - 19:10
File harbour-meerun-1.8.3-1.armv7hl.rpm4.26 MB21/07/2014 - 02:47
File harbour-meerun-1.8.4-1.armv7hl.rpm4.27 MB22/07/2014 - 23:44
File harbour-meerun-2.2.0-1.armv7hl.rpm2.49 MB24/12/2014 - 00:33
File harbour-meerun-2.2.1-1.armv7hl.rpm3.83 MB24/12/2014 - 01:30
File harbour-meerun-2.2.2-1.armv7hl.rpm3.83 MB24/12/2014 - 02:27
File harbour-meerun-2.3.0-1.armv7hl.rpm3.89 MB23/03/2015 - 21:28
File harbour-meerun-2.3.1-1.armv7hl.rpm4.05 MB30/03/2015 - 14:51
File harbour-meerun-2.3.2-1.armv7hl.rpm4.05 MB01/04/2015 - 14:26
File harbour-meerun-2.3.4-1.armv7hl.rpm4.05 MB26/04/2015 - 02:23
File harbour-meerun-2.4.4-1.armv7hl.rpm4.1 MB02/06/2015 - 04:05
File harbour-meerun-3.3.14-1.armv7hl.rpm7.5 MB13/06/2016 - 00:33
File harbour-meerun-3.3.15-1.armv7hl.rpm7.47 MB13/06/2016 - 23:14

- Fixed package issue


pasik2's picture

Newest OS update fixed this.

markouu's picture

MeeRun v3.3.15 crashes when you open a new training and adjust the heart rate monitor settings. Sailfish OS is

moli's picture

Issue confirmed. What to do? Anyone found a solution or workaround?

jdrescher's picture

Yeah, I got the same problem. Really annoying.

Has anyone a fix for that?

BonoNL's picture

I think this is one of the best apps on SailfishOS.


Really like it and use it a lot!

pkz's picture

I cannot install it because of missing package: qt5-plugin-geoservices-osm

jdrescher's picture

Same for me. Can't install on Aurajoki because of this missing package.

When I try to install package by hand I get this error:

Fatal error: qt5-plugin-geoservices-osm-5.2.1+git9-1.25.1.armv7hl requires qt5-qtlocation = 5.2.1+git9-1.25.1, but this requirement cannot be provided


Maybe there is a workaround for this?


caprico's picture

Open terminal and enter:

pkcon refresh

Now try to install it again (and make sure you install the latest version).

hetas's picture

Noticed a little bug in the latest version.

Setting custom distance doesn't work right. If i set distance for exemple to 7km, it is actually set to 77km. If i go to edit the distance it shows as 7km.

  • Meerun v3.3.15
  • Jolla Phone, Sailfish OS v2.0.1.11 (Taalojärvi)
  • Finnish locale


EMKAH's picture

I still got the gstreamer0.10 missing dependency error. :/ Any actual workarounds?

mattl's picture

Program closes if choose my Polar iWL in HRM menu while starting new workout.

meerun 3.3.15 and sailfish

paulvt's picture

Second that, I have that too.  I haven't ran with the new version yet, so I don't know if it's just the settings page or the entire HRM implementation?

ArnoldJudas's picture

Love this app.
The only thing missing is the Jolla Tablet support, to look at the new data on a better/bigger screen than on the phone itself.

mdosch's picture

Thank you for mentioning this. I want to use meerun today after a long time no sports and I went crazy when I didn't find the option to start a new workout.

LVPVS's picture


If I set a Goal and set it to announce, MeeRun respects my setting (it is also present in the config file), but it does not show up on the GUI (always displays 'disabled' upon returning from another page)...

Just a minor glitch, but still. :)

LVPVs over.

ziellos's picture

I am wondering if the old, first-generation SportsTracker HR belt (Polar bluetooth) is compatible? When I try to activate HR monitoring by tapping the "Polar iWL" device, the MeeRun app is closed immediately. The Polar iWL is shown as paired device in settings - bluetooth, and the only supported protocol is SPP according to that list.

The same HR belt works well when paired with my Nokia 808 Symbian device.

haruotsa's picture


I have also same problem with "Polar iWL" selection. Before update everything worked perfectly. Do you have any tips how i can use pedometer. I can't see any steps after the workout?

LVPVS's picture


I noticed that on Jolla the step counter only works if the phone's screen is on.
In other words, if the device is locked, don't expect it to work.

LVPVS over.

LVPVS's picture


I figured that step counting stops as soon as my phone goes to deep sleep (suspend) 20 minutes after the last interaction (+ screen time-out).

LVPVS over.

hwesselmann's picture

Thanks for the update! I have bought the pro version on iOS in order to give some support. Again a big 'Thank you' for supporting SailfishOS!

tvicol's picture

Upgraded to 3.3.15-1. Exceptional application !

Donated. Thank you !

beak's picture

with version harbour-meerun-3.3.14-1.armv7hl.rpm i have same problem

when i install harbour-meerun-3.3.15-1.armv7hl.rpm i have other problem:

rpm -Uhv harbour-meerun-3.3.15-1.armv7hl.rpm
error: Failed dependencies:
        qt5-qtmultimedia-plugin-mediaservice-gstaudiodecoder is needed by harbour-meerun-3.3.15-1.armv7hl

to solve this:


pkcon refresh

pkcon update

pkcon install qt5-qtmultimedia

pkcon install qt5-qtmultimedia-plugin-mediaservice-gstaudiodecoder

rpm -Uhv harbour-meerun-3.3.15-1.armv7hl.rpm

and install meerun 3.3.15 succes



paulvt's picture

The harbour application did all this automatically for me. Your solution probably works too, but why do the dependency installation manually?

pagis's picture


I got an error trying to install 3.3.14-1.armv7hl

nothing provides libc.so6(GLIBC_2.0) needed

where can we get libc.so6?

Vieno's picture

I'm hv'ing the same issue.

May due to the fact I installed it using "rpm -Uhv --nodeps" to overcome the gstreamer problem.

Anyway. I really like this program, hence I donated for it.

Klipata's picture

Got  the same error  

hoschi's picture

Thanks for your work Walter! I'm eager to see the new release, as soon as the bluetooth/libc-issue is fixed. Another question, do you think adding Meerun to the official store is now possible? You have written in the past, that the missing map/location-framework in pre SailfishOS 2.0 was the blocking part.




bwalter's picture

As far as I know, there are still the same restrictions. I hope that SailfishOS will support more recent versions of Qt in the near future (with QtLocation and QtBluetooth with BTLE support). It would be great to be able to add MeeRun to the Harbour!

hoschi's picture

Thanks! Your not the only one who is waiting for Qt "5.5" ;)

The start screen looks far better, not only the icons but also the recorded-tracks are better visible. Same for some of the details, especially the elavation. But I see a problem with starting a new workout, the "pulley" menu is nearly hidden at the bottom and I need some seconds to grasp, that I have to pull the icons and not the recorded-tracks. I'm afraid newbies will miss it entirley. If I remember correctly, that Human-Interface-Guidlines (HIG) suggest a limit of 4(?) items per pulley. In this case, I would break the rule and add "new workout" and "manual workout" in the top pulley (Jolla uses 5 in mail).




bwalter's picture

Sorry for the late reaction. New update is now available!