MeeRun Sports Tracker

Your rating: None Average: 4.9 (75 votes)

MeeRun is a GPS Sports Tracking application which provides a user-friendly and powerful way to manage your sport activities. It has a strong focus on accuracy and usability but also provides innovative and unique features like the facility to replay a session, a detailed elevation profile and an integrated lock screen.

Main features:file format
- For jogging, biking, hiking, skating, sailing, driving, flying and more
- Real-time distance, time, lap, speed, pace, heart rate, elevation, calories, ...
- Audio feedback (English and German): regular and manual updates
- Map: OpenStreetMap, Nokia maps
- Heart Rate Monitoring (HRM)
- Manual and auto-pauses
- Online + offline filter
- Lock screen (with run info and swipe-to-unlock)
- Split table
- Elevation profile (distance, grade, gain/loss, ...)
- Statistics and charts (speed, intervals, elevation, heart rate, HR zones, ...)
- Interactive review with timeline
- GPX import/export
- Minimal resource usage
- Light-weight and intuitive UI
- No ads, no account required, no registration needed, no ad!

Heart Rate Monitoring

To be able to monitor your heart rate, you will need a Bluetooth (non-smart) device (Zephy HxM BT, Polar Wearlink+, ...). Sports Tracker devices have been reported to work but are not officially supported

Application versions: 
File harbour-meerun-1.7.90-1.armv7hl.rpm4.24 MB14/05/2014 - 19:10
File harbour-meerun-1.8.3-1.armv7hl.rpm4.26 MB21/07/2014 - 02:47
File harbour-meerun-1.8.4-1.armv7hl.rpm4.27 MB22/07/2014 - 23:44
File harbour-meerun-2.2.0-1.armv7hl.rpm2.49 MB24/12/2014 - 00:33
File harbour-meerun-2.2.1-1.armv7hl.rpm3.83 MB24/12/2014 - 01:30
File harbour-meerun-2.2.2-1.armv7hl.rpm3.83 MB24/12/2014 - 02:27
File harbour-meerun-2.3.0-1.armv7hl.rpm3.89 MB23/03/2015 - 21:28
File harbour-meerun-2.3.1-1.armv7hl.rpm4.05 MB30/03/2015 - 14:51
File harbour-meerun-2.3.2-1.armv7hl.rpm4.05 MB01/04/2015 - 14:26
File harbour-meerun-2.3.4-1.armv7hl.rpm4.05 MB26/04/2015 - 02:23
File harbour-meerun-2.4.4-1.armv7hl.rpm4.1 MB02/06/2015 - 04:05
File harbour-meerun-3.3.14-1.armv7hl.rpm7.5 MB13/06/2016 - 00:33
File harbour-meerun-3.3.15-1.armv7hl.rpm7.47 MB13/06/2016 - 23:14

- Fixed package issue


bwalter's picture

It should be addressed in the next release :)

megger75's picture

Great App! I like the Data Export. Works stable. Thank you for this super App!!

petrikk's picture

Hi. I'm not able to test audio feedback (EN version). Looks like it's not working, at least for me. Does anybody else have same issue?

bwalter's picture

The new 2.3.0 release is now available. Thanks a lot for the feedback we received! There will be another bug-fix release in the next days and soon afterwards, a nice surprise :)

For more information about the new release, please refer to the changelog. And as usual, your feedback is more than welcome!

Jordi's picture

Very happy to see that MeeRun is still alive!

bwalter's picture

More than ever ;)

nkadithya31's picture

Feature request: meerun auto upload to endomondo

Hemmostiina's picture

Playlist and sounds will not work

Lainen's picture

The app is very good and accurate I think,any plans for adding a step couter in It?to use offline?

mannisville's picture

Great app but I don't get how to export GPX-files?

mannisville's picture

Ok, now I found it: upswipe inside the workout. I thought I can export all the workouts at once and look for it in the main screen.

cizi's picture

Hi there, first of all thank you for your great app! I find it very useful :-).. so, I have just one question. When i'am importing my data from sportstracker every single workout has the activity "Runnung" but I have more kinds of activities. Is a problem in MeeRun app or in my files? Do you have (anyone) similar problem?

THX a lot

silverhook's picture

I have tried to find the source code to MeeRun, but cannot find it.

Somewhere in my mind it was that MeeRun is Free Software (as in freedom, not as in beer) …did I remember it wrongly?

BobTheBodybuilder's picture

I found a bug. If you view some old workout then you cannot start a new workout or import workouts.

And it might be useful to have a quick scroll(like some apps have) in the workout list so you could go fast to the latest workout if you were checking some old workouts.

romu70's picture


As many, MeeRun doesn't start anymore on Update 10. What's strange is Warehouse says the most updated version is and not the 2.2.x. Weird.

nkadithya31's picture

When I start a new work out I get an error saying GPS not avaliable but in the map I can see my current location. Is this a bug?



lunatix's picture

Looks like audio feedback doesn't work, is it the same for anyone else? Button fom headset is not functional either...

boertje1977's picture

I am not able to start meerun from the GUI, when i start it in command-line i can start meerun. Anyone else this issue?

I am running

edj's picture

Same problem here, it launches just fine when started from the terminal. Permissions are the same as other applications

edj's picture

Reboot after reinstall fixed it!

bwalter's picture

Can you see the file /usr/share/applications/harbour-meerun.desktop?  Anything wrong in the contents or with the file permissions?

boertje1977's picture

After reboot of the phone the problem is solved....

Thanks all.

boertje1977's picture

Permissions look actually the same as other applications.

gabriel's picture

Permissions look the same as any other file (rw for root, r for everybody else), and as for content it looks ok, Exec=harbour-meerun, which is exactly how I execute it from CLI.

boggins's picture

I had the same issue with starting from icon vs starting from terminal (i.e. could not start from icon, only from terminal). I removed original and re-installed, and had the same problem. I restarted the phone, and the problem was gone - I can now start from icon. 

rolfa's picture

I can confirm that: Reinstall, than reboot. Now it works when starting from icon.


gabriel's picture

Same here, tried to uninstall+install and same dice.

BobTheBodybuilder's picture

When you view map of recorded workout in fullscreen you can't exit that fullscreen map.

Is the icon changed? I have the same old icon.

bwalter's picture

Exit fullscreen should be fixed in 2.2.2. The icon is supposed to be changed, maybe you need to explictly uninstall the old version?

bwalter's picture

The new 2.2.0 release has just been uploaded! Please note that it has not been fully tested yet, that's why your feedback and bug reports are very welcome :)