Microtube

Rating: 
4.76087
Your rating: None Average: 4.8 (46 votes)

This app is an alternative youtube client based on minitube. You can watch videos and subscribe to channels. There is no login to youtube account. Subscriptions are offline.

IMPORTANT! In order for microtube to work, you need to install Kabouik's nodejs app from here

Subscriptions can be imported. Import is in pulldown menu on subscriptions page.

Youtube api key is required to run this app. That's unfortunate but required due to recent google api changes.

No longer! No API key required!

If you scroll left on main screen you will have access to categories. You can set default category in settings

Filters are only available if you search for something.

To cast to jupii, jupii needs to be running first and connected to device.

Microtube uses SponsorBlock plugin

You can donate me here paypal.me/MisterMagister

Screenshots: 
Application versions: 
AttachmentSizeDate
File microtube-1.8.2-1.armv7hl.rpm192.13 KB03/06/2020 - 18:31
File microtube-1.8.2-1.i486.rpm216.78 KB03/06/2020 - 18:31
File microtube-2.0-1.armv7hl.rpm281.09 KB01/10/2020 - 19:38
File microtube-2.0-1.i486.rpm335.44 KB01/10/2020 - 19:38
File microtube-2.1-1.armv7hl.rpm332.53 KB25/03/2021 - 14:41
File microtube-2.1.1-1.armv7hl.rpm332.61 KB30/03/2021 - 00:06
File microtube-2.1.2-1.armv7hl.rpm337.87 KB03/04/2021 - 15:26
Changelog: 
  • Fixed missing translations (if I removed some translations from already existing ones, please re-do those)
  • Updated Swedish translation
  • Updated Spanish translation

Comments

enrish's picture

Hi, I've been happily using your app all the time. Now I think I found a bug. I have been hesitating before reporting as I can't reproduce it every single time.
I keep 'Adjust brightness automatically' activated in my display system settings. When I start Microtube it overrides the 'optimal' brightness level and the screen gets less bright (don't know if this is intended, but I find it defeates the purpose of having automatically brightness on - and this happens also with picoplayer). Now the bug is that when I close Microtube I find that the 'Adjust brightness automatically' setting has been deactivated.
This happens about 80% of the times. Sorry I could not find the exact steps to reproduce it, but I made sure this only happens after using Microtube.

uddghsjauszg's picture

For some reason it works on an other internet connection, strange. Thanks anyway

uddghsjauszg's picture

Umm for some reason it stopped working. Anyone also experiencing this?

ferlanero's picture

cd .local/share/microtube/microtube/js/ & npm update

Mister_Magister's picture

Try reinstalling nodejs, it helped for me. or you can try reinstalling both if it doesn't help. I suspect that node_modules need to be updated

 

uddghsjauszg's picture

Thank you very much for this project! I like it so much and it is very nice to have a still maintained yt player to help this platform become truly capable of a daily driver.

elkiaer's picture

Thanks, did not know that.
Useful if you only want to download sound.

Mister_Magister's picture

Or if you are listening to music/podcast

elkiaer's picture

When I use the app only the sound is present, there is no video.

Mister_Magister's picture
cquence's picture

Any chance of getting a 64bit version? Thanks!

Mister_Magister's picture

Currently sfos is too unstable to run 64bit microtube so we are waiting for sfos to get more stable

usernamenotavailable's picture

Hey can u add comments, doesnt matter to me if it needs api key. Great client btw

Mister_Magister's picture

will think about it

rossholmes's picture

Finally a working YT client - thank you for this!

Mighty's picture

The videos dont play, searching works but when the video comes it just keeps loading.
(I have defaultuser and not nemo)

rossholmes's picture

Same for me, unfortunately

Mister_Magister's picture

just restart app

Mighty's picture

well reflashed sailfish now dont get that internet issue, but the videos still do not play :(

Mister_Magister's picture

Noone said anything about reflashing sailfish. restart app

Mighty's picture

ohk wow it worked now, guess it takes a long time to load thanks for the help and the app :D
Edit : A few feature requests (no hurries) - subtitles, changing the speed and resolution :)

Mighty's picture

Now it tells to check internet connection, but my wifi is working :(

Mister_Magister's picture

Just try and restart app

rob_k's picture

Great, thanks!

rob_k's picture

Yes, but for the moment I uninstalled Microtube... And it's still active.

Mister_Magister's picture

remove ~/.local/share/applications/microtube-url.desktop
run update-desktop-database ~/.local/share/applications/

rob_k's picture

Okay, thanks! Could you make the setting optional four opening urls with Microtube? I hardly ever need it. It remains after uninstalling too, which is not very useful. The app is very promising though, thanks four developing!

Mister_Magister's picture

I could but i rather wait for my domain handling patch to come in next sfos update

rob_k's picture

I'm searching how to get rid of this option. Mimer doesn't do the trick. What would be the best way to do this?

Mister_Magister's picture

em… it will reinstall itself every time you open microtube ¯\_(ツ)_/¯

Pages