Yottagram

Rating: 
4.5
Your rating: None Average: 4.5 (34 votes)

You no longer need tdlib package to run this app. It's safe to remove. 
 

If you want calls to be working you need to install voicecall plugin. Remember to reboot phone afterwards! Yottagram should pull it along but it's not required.

If you want to have yottagram in share menu you need to install transferengine plugin.

 

A telegram client that's superfast and super smooth. We want to make it as close to official app as possible. Forget the days of using telegram desktop or laggy crashy apps. Welcome to the future.

 

Trello (development process): https://trello.com/b/nDmAfkoG/yottagram-development-issues

Github: https://github.com/Michal-Szczepaniak/Yottagram

Paypal: https://www.paypal.me/MisterMagister

Patreon: https://www.patreon.com/Mister_Magister

Screenshots: 
Application versions: 
AttachmentSizeDate
File yottagram-0.1-1.armv7hl.rpm794.3 KB22/10/2020 - 10:32
File yottagram-0.1.1-1.armv7hl.rpm794.75 KB27/10/2020 - 19:55
File yottagram-0.1.2-1.armv7hl.rpm800.64 KB01/11/2020 - 22:33
File yottagram-0.1.3-1.armv7hl.rpm851.16 KB20/11/2020 - 21:03
File yottagram-0.1.3-1.i486.rpm980.62 KB20/11/2020 - 21:03
File yottagram-0.1.3-1.aarch64.rpm950.54 KB16/05/2021 - 00:16
File yottagram-0.2.0-1.armv7hl.rpm987 KB07/11/2021 - 19:05
File yottagram-0.2.0-1.aarch64.rpm1.03 MB07/11/2021 - 19:05
File yottagram-0.2.0-1.i486.rpm1.12 MB08/11/2021 - 01:54
File yottagram-0.2.4-1.aarch64.rpm11.54 MB04/12/2021 - 18:37
File yottagram-0.2.4-1.armv7hl.rpm11.11 MB04/12/2021 - 18:37
File yottagram-0.2.4-1.i486.rpm13.11 MB04/12/2021 - 18:37
File yottagram-0.2.8-1.armv7hl.rpm13.5 MB23/01/2022 - 12:38
File yottagram-0.2.8-1.i486.rpm15.57 MB23/01/2022 - 12:38
File yottagram-0.2.8-1.aarch64.rpm14.05 MB23/01/2022 - 12:38
File yottagram-0.2.9-1.aarch64.rpm14.05 MB14/04/2022 - 11:20
File yottagram-0.2.9-1.armv7hl.rpm13.51 MB14/04/2022 - 11:20
File yottagram-0.2.9-1.i486.rpm15.58 MB14/04/2022 - 11:20
Changelog: 
  • fix launching on 4.4

Comments

ddoveb's picture

I'm not receiving a validation code after entering my phone number (Spanish).

uddghsjauszg's picture

Hi, calls don't work for me unfortunately. The other person recieves the call but I can't see nor hear anything. Neither I can end the call.

carmenfdezb's picture

You have to install voicecall-yottagram-plugin: https://openrepos.net/node/11510

nowave7's picture

How does one start a new chat? Or goes through the list of contacts?

Mister_Magister's picture

If you mean that chat list is empty, try restarting app

carmenfdezb's picture

It's the only telegram client that works atm and the only one that supports voice calls. @Mister_Magister, you did a hard work! Thank you for your effort! You always surprise me :)

uddghsjauszg's picture

wtf calls don't work for me rip

Mister_Magister's picture

Did you install the plugin?

paolomi's picture

Hi :) Is it possible to install it on jolla-phone? It tells me:

Fatal error: nothing provides libcrypto.so.1.1 needed by yottagram-0.2.4-1.armv7hl
nothing provides libcrypto.so.1.1 needed by yottagram-0.2.4-1.armv7hl

 

Thanks a lot in advance.
 

lpr's picture

here you go:https://openrepos.net/content/lpra7/openssl-111

 

the search engine here on openrepos does work, just use it

Mister_Magister's picture

Holy heck i was actually thinking of doing something like this, now i can use yotti on my x2 without updating it (which i ofcource eventually will)

lpr_A7's picture

yes, but if it has SFOS3.4 or less, you will have to make sure that https://openrepos.net/content/lpra7/openssl-102-legacy-jollaphone-x-xa2 is installed too (warehouse/storeman or adding lpr_a7 repo will handle that automatically). I just made that explicit in the package notes... it just behaves like a jolla1 then.

Mister_Magister's picture

Well i learned it hard way so instead of doing that i reverted back to old openssl and then copied libssl and libcrypto from your package

lpr's picture

hm, really sorry for that, don't know how that could happen (updating only without throwing an error).

 

With the old jolla Package you are vulnerable to CVE-2018-5407 CVE-2020-1968 CVE-2020-1971 CVE-2021-23840 and CVE-2021-23841 and every CVE that is found in 1.1.1l which would be closed in 1.1.1m+

 

so manually adding 1.1.1l libraries is not recommended...

Mister_Magister's picture

not to mention i will be making 4.2 update for my x2 soon

lpr's picture

then, I would recommend https://openrepos.net/content/openssl111102/openssl-libs-111-102 as this is the version of SFOS4.2

Mister_Magister's picture

with 3.4 kernel i sure have more problems than vulnerable openssl xd

paolomi's picture

Thanks a lot!!!!

Mister_Magister's picture

Unfortunately :/ it requires 4.x sfos. 

tport's picture

After launching, I see "UI Template" and a text field with label "Number with +XXX". I can put my phone number in the text field, but where to go from there? There is no button, and pressing enter does not do anything. :(

Mister_Magister's picture

You have to wait for new update. Telegram doesn't allow login from older apps

tport's picture

That's a shame. I wanted to give this a try, since official telegram forced an upgrade today, and with the newest version voice messages don't work.

Mister_Magister's picture

worry not, update is coming really soon

kettcar64's picture

Thanks for the quick update!

baboo's picture

Thank you for your work. Always.
Seems the daemon is working just fine again. Much appreciated.

ferlanero's picture

Yottagram in tablet: best Telegram experience ever.

elderorb's picture

Good! Any ETA for it?

Mister_Magister's picture

not really i have other priorities now

elderorb's picture

Does it support folders?

Mister_Magister's picture

It actually does, i just didn't add gui for it

Pages