Gstreamer 1.16.2 (JollaPhone & X & XA2)

Rating: 
5
Your rating: None Average: 5 (1 vote)

derived from https://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-1.... + gst-bad-1.16.2git + Jolla-git2 Patches
makes use of (if installed separately):
openEXR2.2 libfaad2 libfaac0 libx265.so.188 libde265.so.1 libmms0 libdca0 libmplex2 libmpeg2encpp-2.1_0 librtmp1 libfdk-aac.so.2

requires: Rokua (3.3.0) , libvo-aacenc (availabe in official repo), aom

(version 1.8.3 & 1.10.5 & 1.14.4 still available here, too)

sha256sum / filename:
ad0194e89287ef7e20b7f90c97def8c7475ca8c8bea8f6a11d577f458cdab614 gstreamer1.0-1.16.2+git2-5.armv7hl.rpm
8642d8461b118f747426fa0775c6ea11e3488fbe4430ff2599c6992d18d4b7e1 gstreamer1.0-devel-1.16.2+git2-5.armv7hl.rpm
325c7a23eb48cc7b76220c2301424793ac4e7709ddf5366559b6d85a813e0461 gstreamer1.0-plugins-base-1.16.2+git2-5.armv7hl.rpm
09aa108d22853a07a7d4ab4276859a374e1f0aeeb3a0bffba499bc353ec6e660 gstreamer1.0-plugins-base-apps-1.16.2+git2-5.armv7hl.rpm
0acce502de4a1705c3173def750a17e51bf1d919c6c4ea1f0652c1aee91b0a5e gstreamer1.0-plugins-base-devel-1.16.2+git2-5.armv7hl.rpm
94dc4cc0b1e7f03d138d313fc06e47bc0484fc634e3f44273af3ec5b2d74b10b gstreamer1.0-tools-1.16.2+git2-5.armv7hl.rpm
1ad0bdf95388eb51cb84183eb76eb35e06ab213adcb98d53249e50e4df86c252 gstreamer1.0-plugins-good-1.16.2+git2-4.armv7hl.rpm
3650315632d2a81db5e280efd0cc76449c227c5349f6dee943ff67d40df5e2e1 gstreamer1.0-plugins-good-extra-1.16.2+git2-4.armv7hl.rpm
923fe8f44326df5a241e31eeaf6904545dbc6c978ac305622bebb22580746f3c gstreamer1.0-plugins-bad-1.16.2+git2-4.armv7hl.rpm

Category:

Application versions: 
AttachmentSizeDate
File gstreamer1.0-plugins-bad-1.8.3git1-2.1.1.armv7hl.rpm8.35 MB27/11/2016 - 18:25
File gstreamer1.0-plugins-bad-1.8.3git1-3.1.1.armv7hl.rpm8.96 MB25/03/2017 - 18:21
File gstreamer1.0-plugins-bad-1.10.5git1-2.armv7hl.rpm10.2 MB29/08/2017 - 17:26
File gstreamer1.0-plugins-bad-1.10.5git1-3.armv7hl.rpm10.2 MB07/02/2018 - 00:01
File gstreamer1.0-plugins-bad-1.14.3git1-1.armv7hl.rpm8.42 MB24/09/2018 - 01:01
File gstreamer1.0-plugins-bad-1.14.4git2-1.armv7hl.rpm8.42 MB10/10/2018 - 01:36
File gstreamer1.0-plugins-bad-1.14.4git3.1-2.armv7hl.rpm8.43 MB27/01/2019 - 16:29
File gstreamer1.0-devel-1.16.2-3.armv7hl.rpm568.21 KB03/04/2020 - 18:05
File gstreamer1.0-tools-1.16.2-3.armv7hl.rpm48.72 KB03/04/2020 - 18:06
File gstreamer1.0-1.16.2-3.armv7hl.rpm2.57 MB03/04/2020 - 18:08
File gstreamer1.0-plugins-base-devel-1.16.2git2-3.armv7hl.rpm338.61 KB03/04/2020 - 19:22
File gstreamer1.0-plugins-base-apps-1.16.2git2-3.armv7hl.rpm31.56 KB03/04/2020 - 19:22
File gstreamer1.0-plugins-base-1.16.2git2-3.armv7hl.rpm5.11 MB03/04/2020 - 19:26
File gstreamer1.0-plugins-good-extra-1.16.2-3.armv7hl.rpm127.24 KB03/04/2020 - 22:19
File gstreamer1.0-plugins-good-1.16.2-3.armv7hl.rpm8.91 MB06/04/2020 - 23:26
File gstreamer1.0-plugins-bad-1.16.2git2-3.armv7hl.rpm8.72 MB07/04/2020 - 03:57
File gstreamer1.0-plugins-base-1.16.2git2-4.armv7hl.rpm5.21 MB30/05/2020 - 08:33
File gstreamer1.0-plugins-base-devel-1.16.2git2-4.armv7hl.rpm338.59 KB30/05/2020 - 08:33
File gstreamer1.0-plugins-base-apps-1.16.2git2-4.armv7hl.rpm31.65 KB30/05/2020 - 08:34
File gstreamer1.0-plugins-good-extra-1.16.2git2-4.armv7hl.rpm127.47 KB30/05/2020 - 08:35
File gstreamer1.0-plugins-good-1.16.2git2-4.armv7hl.rpm6.14 MB30/05/2020 - 08:42
File gstreamer1.0-devel-1.16.2git2-5.armv7hl.rpm532.88 KB05/06/2020 - 20:12
File gstreamer1.0-tools-1.16.2git2-5.armv7hl.rpm48.95 KB05/06/2020 - 20:12
File gstreamer1.0-1.16.2git2-5.armv7hl.rpm2.56 MB05/06/2020 - 20:15
File gstreamer1.0-plugins-base-devel-1.16.2git2-5.armv7hl.rpm338.63 KB05/06/2020 - 20:16
File gstreamer1.0-plugins-base-apps-1.16.2git2-5.armv7hl.rpm31.56 KB05/06/2020 - 20:18
File gstreamer1.0-plugins-base-1.16.2git2-5.armv7hl.rpm5.21 MB05/06/2020 - 20:21
File gstreamer1.0-plugins-bad-1.16.2git2-4.armv7hl.rpm9.23 MB06/06/2020 - 15:53
Changelog: 

vendor-change from pre-installed official jolla-package may require manual command line usage (zypper,pkcon,rpm,...) when warehouse-app refuses to install

- Rokua (3.3.0) release (gstreamer-1.16)

- Sipoonkorpi (3.0.1) release (gstreamer-plugins-bad-1.14+git3)

- updated libgstvpx to use libvpx5-1.7.0
- Jämsänjoki (2.1.1)/ Kiiminkijoki (2.1.2) / Kymijoki (2.1.3) release 1.10.5, built with SDK1701-1

- release for 2.0.5/2.1.0 sdk1701-1 - added vpx and libdv from good and bluez from gst-1.4.5 - vendor-change from official jolla-package may require manual command line usage (zypper,pkcon,rpm,...)

- initial release for 2.0.5/2.1.0

Comments

rob_k's picture

Is there a way to uninstall this, and go back to the Rokua 3.3.0.16 version? Somehow I broke my camera. Both Jolla Camera as AdvancedCam won't work on my XA2 now.

I tried to pkcon remove, but it refused: "will brick your system" Also pkcon --allow-reinstall or pkcon --allow downgrade did not work.

lpr's picture

hm, this version of gstreamer doesn't break your camera, something else broke it (maybe gstreamer1.0-droid was removed - camera doesn't work without it).
First check warnings/errors of jolla-camera by starting it from command-line. The messages in terminal should give a hint what is missing.

You cannot uninstall it as this will break your system, so you have to downgrade the package to jolla-version:
devel-su
zypper in --force gstreamer1.0-1.16.1+git1
then you should get a warning that the rest of the packages should get downgraded too and choose the option to do so

paolomi's picture

Hi :) in the packages you suggest, i've found only:

https://openrepos.net/content/bloodyfoxy/libx264

https://openrepos.net/content/larswad/libdca-005-armv7hl-and-i586

where are the other packages? many thanks :)

lpr's picture

same is true as for the ugly package.

you may search for faad2 here in openrepos

Maybe I will manage to upload free webp package...

no openjpeg2 and no x265 encoder so far, I'm afraid...
Feel encouraged to compile yourself (recommended for libde265, too as the version you may find in some rpm here is compiled in sailfish-sdk and should be compiled on-device due to some cpuid-scans... 1 Frame per 5 seconds -> 30Frames/second [vga])

lpr's picture

if some gst-plugins do not work even if the depending library is installed:
delete ~/.cache/gstreamer-1.0/registry.armv7hl.bin (first gst-inspect-1.0 after that takes a while)