Patch: GPS supplier (for Jolla 1 ONLY)

Rating: 
5
Your rating: None Average: 5 (2 votes)

PLEASE, DON'T USE THIS APP ON JOLLA C !!!

If you already installed it and applied, your file /system/etc/gps.conf is broken and gps will not work for you!
To fix it (as ROOT):
1. Uninstall this app:
pkcon remove sailfishos-gps-supplier
If you get error and can't uninstall, run this commands:
rpm -e --noscripts sailfishos-gps-supplier
cd /usr/share/jolla-settings/pages/gps_and_location
/bin/rm -rf plugins ActionList.qml restart_su* tools.js
pkcon install jolla-settings-system

2. Reinstall 2 packages to fix the gps.conf file:
pkcon install droid-config-l500d
pkcon install droid-system-l500d
Now it should be fixed.

----------------------------------------

This patch can change this Supplier and NTP server inside /system/etc/gps.conf file:
SUPL_HOST=supl.pos.nlp.nokia.com
SUPL_PORT=7275
To Google supplier:
SUPL_HOST=supl.google.com
SUPL_PORT=7276
Or Nokia:
SUPL_HOST=supl.nokia.com
SUPL_PORT=7275

NTP server (Europe (default), Asia and North America):
#Asia
NTP_SERVER=asia.pool.ntp.org
#Europe
# NTP_SERVER=europe.pool.ntp.org
#North America
# NTP_SERVER=north-america.pool.ntp.org
* DON'T forget to press Apply button.
* Before unapplying patch, please restore to Default first!
* Thanks to Ancelad for help.

NOTES:
* If you can't install because of this package (lipstick-qt5-tools), open terminal as ROOT and run:
pkcon refresh
When it finish, run:
pkcon install lipstick-qt5-tools
After this try to install my package again.

v0.1-4
- Compatible with v2.0.3.11.
- Reapply your changes after update.

v0.1-3
- File /etc/gps.conf restored as a symlink, now it use real file /system/etc/gps.conf.
- Added option to change NTP server (regions Europe (default), Asia and North America).
- Reapply your changes after update.
- Compatible with v2.0.1.11 & 2.0.2.45..

v0.1-2
- Small changes in .spec file.
- Compatible with v2.0.1.11 & 2.0.2.45.

Beware, use it on your own risk !!!

Donation are welcome :)

Screenshots: 
Application versions: 
AttachmentSizeDate
sailfishos-gps-supplier-0.1-1.armv7hl.rpm10.97 KB27/05/2016 - 07:46
sailfishos-gps-supplier-0.1-2.armv7hl.rpm10.6 KB25/06/2016 - 04:09
sailfishos-gps-supplier-0.1-3.armv7hl.rpm12.4 KB26/06/2016 - 15:33
sailfishos-gps-supplier-0.1-4.armv7hl.rpm12.25 KB23/07/2016 - 17:49
Changelog: 

- Compatible with v2.0.3.11. - Reapply your changes after update.

Comments

olf's picture

[Regression due to SFOS update]
v0.1-4 fails to apply in Patchmanager (v2.3.3-10.41.1 used) under SailfishOS 2.1.1.26

Side note: v0.1-4 was applicable and working under SailfishOS 2.1.0.11 (used Patchmanager 2.3.1-10.39.1 with SFOS 2.1.0.11).

Schturman's picture

Hmmm, still someone need this ? Maybe later I will update it...

explit's picture

Hi Schturman.

Have a problem to uninstall this Package

 

Got this:

Error: Subprocess failed. Error: RPM failed: sed: couldn't open temporary file /system/etc//sedy6nmnP: Read-only file system
sed: couldn't open temporary file /system/etc//sedJHEOjQ: Read-only file system
error: %preun(sailfishos-gps-supplier-0.1-3.armv7hl) scriptlet failed, exit status 4
error: sailfishos-gps-supplier-0.1-3.armv7hl: erase failed

 

Any idea?

Schturman's picture

try to reinstall this version
pkcon install sailfishos-gps-supplier
and after this uninstall as root:
pkcon remove sailfishos-gps-supplier.
if still not help, try:
rpm -e --noscripts sailfishos-gps-supplier
Should work.

explit's picture

Thanks, that worked !!!

pseudoscion's picture

What benefits can changine GPS supplier give you?

Schturman's picture

Maybe more fast will connect...

vbelloir's picture

Hi Schturman,

got an error during installation : "nothing provides sailfish-utilities needed by Sailfishos-gps-supplier-0.1-1.armv7hl"

lipstick-qt5-tools  is correctly installed.

Sailfish OS 2.0.1.11.

 

Do you have an idea?

Vincent

 

Schturman's picture

Install sailfish utilities from jolla store

vbelloir's picture

It works.

Thanks!

elfio's picture

Hello, this is great! Do you think it would be possible to add other providers like Mozilla or Apple?

Schturman's picture

Hi. I can add this if you will provide a correct SUPL_HOST= and SUPL_PORT=. But I really don't know if it will work or not ;)

elfio's picture

Well, sadly I don't know this information from these providers I was talking about. I figured out that Mozilla's has this structure:

https://wiki.mozilla.org/CloudServices/Location/Software#Firefox_Desktop

And I didn't find anything about Apple's :-/

Schturman's picture

Sorry, I also don't know...