ffmpeg

Rating: 
4.833335
Your rating: None Average: 4.8 (6 votes)

FFmpeg: a complete, cross-platform solution to record, convert and stream audio and video.

Requires:
libaom.so.3
libass.so.9
libbluray.so.2
libbs2b.so.0
libbz2.so.1
libcairo.so.2
libcelt0.so.2
libcodec2.so.1.0
libcrypto.so.1.1(OPENSSL_1_1_0)
libdav1d.so.6
libdrm.so.2
libfdk-aac.so.2
libfontconfig.so.1
libfreetype.so.6
libfribidi.so.0
libgme.so.0
libgsm.so.1
liblilv-0.so.0
liblzma.so.5(XZ_5.0)
libmodplug.so.1
libmp3lame.so.0
libmysofa.so.1
libopencore-amrnb.so.0
libopencore-amrwb.so.0
libopenh264.so.6
libopenjp2.so.7
libopenmpt.so.0
libopus.so.0
librabbitmq.so.4
librav1e.so.0
librsvg-2.so.2
librtmp.so.1
libsnappy.so.1
libsoxr.so.0
libspeex.so.1
libsrt.so.1
libssl.so.1.1(OPENSSL_1_1_0)
libtheoradec.so.1(libtheoradec_1.0)
libtheoraenc.so.1(libtheoraenc_1.0)
libtwolame.so.0
libvidstab.so.1.1
libvmaf.so.1
libvo-amrwbenc.so.0
libvorbis.so.0
libvorbisenc.so.2
libvpx.so.7 (libvpx >= 1.11)
libwebp.so.7
libwebpmux.so.3
libx264.so.161
libx265.so.199
libxvidcore.so.4
libz.so.1(ZLIB_1.2.0.2)
libzimg.so.2
libzvbi.so.0

Possible sources for dependencies:
openrepos
https://download.opensuse.org/ports/armv7hl/distribution/leap/15.4/repo/...
https://ftp.uni-erlangen.de/packman/suse/openSUSE_Leap_15.2/Essentials/a...

Screenshots: 
Application versions: 
AttachmentSizeDate
File ffmpeg3-3.4.12-2.armv7hl.rpm6.95 MB02/11/2022 - 23:10
File ffmpeg4-4.4.3-2.armv7hl.rpm7.87 MB02/11/2022 - 23:12
File ffmpeg-devel-5.1.2-2.armv7hl.rpm293.07 KB02/11/2022 - 23:12
File ffmpeg-tools-5.1.2-2.armv7hl.rpm234.02 KB02/11/2022 - 23:12
File ffmpeg-5.1.2-2.armv7hl.rpm8.07 MB02/11/2022 - 23:13

Comments

Termitebug's picture

After a quick install test:

  • ffmpeg-5.1.2-2 install failed
  • ffmpeg4-4.4.3-2 install success (after manual libs install)
  • ffmpeg3-3.4.12-2 install success (after manual libs install)

I'm still missing depencies for ffmpeg5:

libdav1d.so.6 is needed by ffmpeg-5.1.2-2.armv7hl
librtmp.so.1 is needed by ffmpeg-5.1.2-2.armv7hl

librtmp depencies looks terrible:
       libgnutls.so.30 is needed by librtmp1-2.4.*.armv7hl
       libgnutls.so.30(GNUTLS_3_4) is needed by librtmp1-2.4.*.armv7hl
       libhogweed.so.4 is needed by librtmp1-2.4.*.armv7hl
       libhogweed.so.4(HOGWEED_4) is needed by librtmp1-2.4.*.armv7hl
       libnettle.so.6 is needed by librtmp1-2.4.*.armv7hl
       libnettle.so.6(NETTLE_6) is needed by librtmp1-2.4.*.armv7hl

libgnutls.30 sub depencies:

       (where?) crypto-policies is needed by libgnutls30-3.7.3-2.2.armv7hl

       RPM find results