SailfishEase keyboard (fork)

Rating: 
4.81818
Your rating: None Average: 4.8 (11 votes)

Goodbye patchmanager!!
Finally the MessagEase keyboard is available for everyone!
This is a very special keyboard that perfectly combines the usual typing experience with few other swipe gestures allowing you to get rid of all your classical typos.
This keyboard was originally ported (from scratch AFAIK) by Jimmy Huguet on SailfishOS, you can find in his repo on GitLab, but this version was modified in order to properly work with jolla-keyboard.
Now i was finally able to create an independent layout, that does not need patching anymore. So i have consider this a fully featured fork of Jimmy Huguet keyboard.

Available layouts are:
- English
- Italian
- German
- Belarusian-latin
- Norwegian Nynorsk
- Chinese Pinyin (experimental: feedbacks are wellcome)
- Spanish
- Polski
Available but not tested by natives:
- Dutch (Nederlands)

If you need a different characters map or different accents for your language send me your request (a simple drawing is better) or you can create it yourself and share it with the community :)
Source code here, Hugs and feedbacks are welcome!

N.B. If you istalled any version previous than the openrepos landing, it's better if you remove that before installing this one. (contact me if you have any doubt on how to)

# How to use it
The 9 most used letter are in a 3x3 grid, just tap the letter to input any of the 9

  • to input "a", just tap on "a"

the remaining of the alphabet is showed around each of the 9 letters : you swipe from that letter to the direction of the letter you want, the letter selected is shown instead of the main letter, inside the circle

  • to input "k", press "h" then swipe to the right

Special characters are available but not shown by default, you can tap the bottom left key "*.$" to make them appear.
At any time (whether they are visible or not) you can input a special character the same way you input other letter

  • to input ".", press "e" then swipe down

Numbers are available by pressing the "?123" key on the right.
You can input accentuated characters by entering the diacritics you want to use after the character

  • to input "é", input "e" then input "´" ("n" then swipe up-right)

if you wanted to input two characters but they got automatically merge, you can press the erase key on the top right (the arrow with a X)

  • if you wanted to input "e´" but you got "é", just press erase

# Acknowledgements
Very big thanks to Jimmy Huguet for coding this amazing keyboard, and a SPECIAL thank to 247 for all the important bug reports and testing :)
Thanks also to Dagi for the Norwegian layout and to all others community members for sharing their language layout!

Screenshots: 
Application versions: 
AttachmentSizeDate
File sailfish-ease-vkb-0.1.4-1.noarch.rpm55.61 KB06/12/2018 - 13:07
File sailfish-ease-vkb-0.1.4-2.noarch.rpm55.77 KB07/12/2018 - 11:52
File sailfish-ease-vkb-0.1.5-1.noarch.rpm54.82 KB14/12/2018 - 17:44
File sailfish-ease-vkb-0.1.6-1.noarch.rpm54.84 KB15/12/2018 - 00:42
File sailfish-ease-vkb-0.1.6-2.noarch.rpm55.13 KB15/12/2018 - 16:24
File sailfish-ease-vkb-1.0.2-6.noarch.rpm58.44 KB16/04/2019 - 23:13
File sailfish-ease-vkb-1.0.2-7.noarch.rpm58.49 KB24/04/2019 - 22:54
File sailfish-ease-vkb-1.0.2-8.noarch.rpm58.49 KB25/04/2019 - 00:15
Changelog: 

Wed Apr 24 2019 Version 1.0.2-8
- Bug fixing

Wed Apr 24 2019 Version 1.0.2-7
- Added "ó" accent in polish layout
- updated dependencies for SFOS 3.0.3.x

Mod Apr 16 2019 Version 1.0.2-6
- Redesigned without patchmanager
- Conformed to jolla-keyboard 0.7.2 (latest version)
- Added Polski and Dutch

Sat Dec 15 2018 Version 0.1.6-2
- Added Español

Fri Dec 14 2018 Version 0.1.6-1
- solved IMPORTANT bugs with accents

Fri Dec 14 2018 Version 0.1.5-1
- Added text prediction
- Swipe trace start from center of the key
- Solved bug of locked traces
- Do not commit accent after accented letter canceling
- Added Chinese Pinyin

Fri Dec 07 2018 Version 0.1.4-2
- Added Norwegian Nynorsk

Tue Dec 04 2018 Version 0.1.4-1
- Adapt to patchmanager
- Adapt to jolla-keyboard swiping gesture

Comments

sdworks's picture

I want to thank you for adding the Dutch translation! Playing with it, it will take some time to learn to use it well ...

foolsbazar's picture

Anyway It was a problem experienced by many using EA, not only with this app. It probably is a Sailfish related problem.
I hope Storeman update makes the deal

t0t3u's picture

After
# pkcon refresh
# zypper in sailfish-ease-vkb
I had the option to install keyboard using Storeman. And it's working great!

foolsbazar's picture

I'm glad to hear that :)

csg1976's picture

RPM from browser works. Thanks!

csg1976's picture

@t0t3u Same here.

t0t3u's picture

O don't have install option after adding your repo.
I'm using SFOS 3.0.3.8. Could this be the reason?
Thanks!

foolsbazar's picture

Something weird, does it happen only with this app? , if pkcon refresh does not help and you have my repo enabled, then for now download from browser the rpm.. While i'll control better this evening

Kabouik's picture

Probably related: my phone is in 3.0.1.11 and the upgrade to 3.0.3.8 hangs on "[75 %] [Install] sailfish-ease-vkb 1.0.2-8 [100 %]".

 

I can't remove the package now to at least finish the upgrade:

----

[root@Sailfish nemo]# pkcon remove sailfish-ease-vkb

** (process:5126): WARNING **: 14:17:30.262: Unable to register authentication agent: GDBus.Error:org.freedesktop.DBus.Error.UnknownMethod: No such method 'RegisterAuthenticationAgentWithOptions'
Error registering authentication agent: GDBus.Error:org.freedesktop.DBus.Error.UnknownMethod: No such method 'RegisterAuthenticationAgentWithOptions' (g-dbus-error-quark, 19)

----

Same with zypper:

----

[root@Sailfish nemo]# zypper remove sailfish-ease-vkb
Loading repository data...
Reading installed packages...
Resolving package dependencies...

The following 2 packages are going to be REMOVED:
  sailfish-ease-vkb sailfish-ease-vkb

2 packages to remove.
After the operation, 206.8 KiB will be freed.
Continue? [y/n/...? shows all options] (y): y
(1/2) Removing sailfish-ease-vkb-0.1.6-2.noarch .............................................................................................................................................................[error]
Removal of (926)sailfish-ease-vkb-0.1.6-2.noarch(@System) failed:
Error: Subprocess failed. Error: RPM failed: error: package sailfish-ease-vkb-0.1.6-2.noarch is not installed
----

Zypper says sailfish-ease-vkb is not installed, but it is. However, Zypper metnions 0.1.6-2 while the issue I got when trying to upgrade SFOS was 0.1.2.8.

 

[Edit] It seems the package was uninstalled anyway, and after that I could complete the SFOS upgrade. Currently rebooting, I hope the interrupted upgrade won't cause any issue!

JacekJagosz's picture

I found a bug, I can't type "ó" which should be a combination of 'o' and '´' (in Polish). Otherwise everything works great

foolsbazar's picture

Thanks for the report :)

dagi's picture

Good work on the standalone version, thank you. 

I finally figured out the long swipe feature, still getting used to it. 

Noticed the keys have drawn borders now, very helpful.

foolsbazar's picture

:)

JacekJagosz's picture

Thank you! It now works on 3.0.2.8, and thanks for Polish language!
Written on Ease keyboard.
The only thing I don't like is that English and Polish use different layout, so I can't just memorize one.

foolsbazar's picture

Yeah, i know the feeling, it's a pity that jolla-keyboard does not allow for choosing separately the layout and the language for text prediction.
If you need english layout with polish text prediction is trivial, just add a file called "en_pl.conf" inside "/usr/share/maliit/plugins/com/jolla/layouts" in which you copy these lines:
[ease_en.qml]
name=Polski-EN (ease)
languageCode=PL
handler=Xt9InputHandler.qml 

toxip's picture

How did you manage to remove the reliance on patchmanager? I am curious to know since I am one of the developers of Japanese flick keyboard and this could help us to also cut the reliance on that as well!

foolsbazar's picture

Sorry to tell you but the answer is cheating. I was able to disable the default MultiPointTouchArea by means of what i would call "parametric children research".
Then i created my own MultiPointTouchArea with the patched input handling. Check in the sourcecode for "searchParentsChild()" inside KeyboardEaseLayout.qml.
Ask me anymore details in Telegram :)
P.S. I'm no programmer, just "code ethusiast", so please don't get mad at me for bad coding practices (nonetheless suggestions are always welcome)

JacekJagosz's picture

There is a bug, at least with the english layout:
Some swipes cause a deletion of last character (like pressing backspace), e.g while trying to type "?".
I don't have any other keyboard mod installed, I'm on newest Sailfish on Jolla 1

foolsbazar's picture

That is actually a feature! Long swipe to the right it's equivalent to spacebar, long swipe to the let is backspace. The actual bug is that in the openrepos version i mistook on writing the value of the trigger level.. so yes, this feature is triggered too easily.

tom_i's picture

Is ir possivle that it doesn't work? I'm on 3.0.1.11 with patchmanager3 beta and ease doesn't installed okish

JacekJagosz's picture

Patchmanager 3 shows it is incompatible wuth anything newer than 3.0.0.8, but for me after installing with Storeman it automatically gets applied and it works.
If you disabled it and can't apply it, reinstall it.

And about thet longer swipe, it is funny this bug is a feature. But now that I know what it is, I'll adjust my typing

247's picture

This is not a bug, it's actually a feature and yuo might expect refinements in that ;)

foolsbazar's picture

I'm sorry i don't remeber if there were changes with SF 3.0.1.11 so it might have been incompatible. The fact is that now i'm working on a version wich won't need patchmanager, so i didn't wont to update the patches.
If the app installs but you cannot apply the patch, try to set developer mode in patchmanager, and retry to apply. If it fails, it means there were changes and i cannot help you right now.

marxistavegana's picture

Trying to figure this out it seems to not swipe to the smaller letters, it jumps from the 9 main letters only. I removed OKeyboard and removed the loopen too. Nevermind Had to fully restart the phone, now it works.

groeable's picture

Cool

sdworks's picture

Any chance you'll get to Dutch?

foolsbazar's picture

My knowledge of Ducth is very close to my knowledge of Chinese... but I'll surely try when I'll have time :)

groeable's picture

Polish?

foolsbazar's picture

Oh well.. yes but I'll need time for that, you have quite a big accents list ^.^'
Belarussian latin shouldn't be far right?

dalas_revo's picture

Always remember to deactivate OKboard or it will drive you crazy because the letter in the circle never changes but you see OKboard's usual traces which you think could belong to this keyboard as well if you never used it before...

Pages