Aliendalvik Superuser

Your rating: None Average: 5 (7 votes)

OOnly for Jolla 1, not work on Jolla C or Intex Aqua Fish or any other device

Superuser is the app that manages what apps on your rooted device have access
to su. Apps that are granted su have elevated permissions and can modify just
about any part of the system. The app was originally written by zinx, and I
took it and made it much more useable. The app consists of two parts,
Superuser.apk and the su binary.

Superuser.apk runs as any other app and gives you, the user, a place to see
what apps you have allowed or denied, as well as view a log of what apps have
used su when.

The su binary is what other apps call when they need superuser rights. The
binary checks the database maintained by Superuser.apk to determine if you have
already granted rights to the requesting app. You must set "Preferences --> Security --> Multi-user mode" to "User controlled" to allow the Superuser.apk to manage Android apps (which request superuser rights) properly. (

Package contains Superuser apk and binary. Removing from launcher does not
remove su binary, you should uninstall package for full uninstallation.

This package obsoletes aliendalvik superuser binary package (

Donations are welcome =)

Application versions: 
File aliendalvik-superuser-3.3-1.armv7hl.rpm850.79 KB16/06/2014 - 16:09


mohammedkukshiwala's picture

Its not working for me ...i have changed the settings from multi user to user controlled . Also i have changed automatic response to prompt also i kept the super user app opened in background and then i tried to run the app with root acess but it does not gives prompt to grant or deny persimission it automaticaly shows d message that permission is denied. Please help to get this fix I m using aqua fish

coderus's picture

Only for Jolla 1, not work on Jolla C or Intex Aqua Fish or any other device

mohammedkukshiwala's picture

Plz make it work for intex aqua fish also

coderus's picture

i tried, but no success :)

olf's picture

As some people seem to have trouble properly installing and configuring Aliendalvik Superuser, here a quick guide:

  1. Aliendalvik Superuser ONLY works on Jolla 1 phones with their AOSP 4.1.2 based AlienDalvik Android runtime environment.
  2. Install Aliendalvik Superuser by Coderus, preferably via the Storeman or Warehouse OpenRepos clients.
  3. Acknowledge the subsequent installation of the Android app Superuser v3.3 by Dave Chen.
  4. Open the Superuser app and tap on the Preferences symbol in the upper right corner: Set Security --> Multi-user mode to User controlled, while leaving Preferences --> Security --> Automatic response on its default (i.e. Prompt).
  5. The Superuser app must be set to start on AlienDalvik startup by activating Settings --> Apps --> Superuser --> Allow application background services to start on bootup, otherwise it cannot capture and filter superuser (su) requests.
  6. Start the Android app you want to grant superuser rights to. You will be prompted, when it requests such rights.

@coderus: Many thanks for Aliendalvik Superuser, this is really excellent work.
And packaging Superuser v3.3 by Dave Chen for SailfishOS / AlienDalvik seems to have been a good choice in terms of quality, reliability and security.

Please also take a look at for screenshots illustrating Superuser's detailed settings as described in

coderus's picture

Done, thanks

olf's picture

As the original suggestion to set Preferences --> Security --> Automatic response to Allow in the Superuser app allows any Android app to gain superuser rights (via the su binary) without user interaction, thus creating a security nightmare on your SailfishOS device, do set Preferences --> Security --> Multi-user mode to User controlled and leave / set --> Automatic response on its default, i.e. Prompt.
Furthermore, these settings reveal the full functionality of the superuser app, including application management and application specific logs.

Other notes:

  • After 5 years without an update, unchecking outdated binary notification in info --> su binary makes sense, in order to keep the Superuser app from calling home unnecessarily. One can still trigger an (always unsuccessful) check manually by tapping on the su binary section.
  • The defaults for all other settings seem to be well chosen (rsp. still reasonable).
  • For screenshots illustrating these settings and Superuser's usage, see
Jordi's picture

It seems that it's not working on the Jolla C. Is it something that you can (+ want) do?


coderus's picture

i'll check as soon as my JollaC arrive :)

Jordi's picture


MoritzJT's picture

You are getting one? I thought that would take ages!

cuh7b5's picture

Is there any solution yet for JollaC?

olf's picture

No, not with this RPM, su binary and Superuser app!






Schturman's picture

Hi. Can you create tablet version, please ?

coderus's picture

no, this one is not working on android 4.4 x86. need different solutions.

masomm's picture

Does anyone have problems in sailfish 2.0 Saimaa?

Works fine before I factory reseted my phone. When I uptaded Jolla again and I try to install Aliendalvik it says installion complete but it doesnt install android app where I could select Allow permission. Also tried to install .apk from file browser but nothing happens.

Any ideas what I could try next, or is there broblem whit newest sailfist version ?

explit's picture

I had the same problems after Upgrade.

My solution was:

1. Uninstall Coderus Aliendalvik SuperUser Package from Warehouse

2. Delete all su binaries ans symlinks from /opt/aliendalvik/system/bin /usr/bin etc.

3. Install Coderus Aliendalvik SuperUser Package from Warehouse

4. In the SuperUser App go to the Settings and Allow Automatic Response on su Access.



daywalker's picture

Today i installed Avira Virusscanner for Android and a trojan was found in this app...


For testing puposes i deleted the app and installed official Superuser from ChainsDD and no trojan was found then...

coderus's picture

This is official app, so nobody cares your avira report ;)

daywalker's picture

Hi coderus, i am getting this error when running "adaway" android app. Similar error with "orbot".

Seems like the apps don't recognize the su binary. I installed your app via warehouse and set it to "always allow" like mentioned above.

The screenshot translates to:

Need rooted Android
Whether the su-binary counld not be found or you didn't give root permissions to adaway.

This counld happen if you didn't root your device. Information on how to root your device can be found on ... or other android websites.

coderus's picture

You need to set Allow to superuser: 

daywalker's picture

i already set it to allow but it doesn't work! i also restarted aliendalvik but no success...

coderus's picture

try to copy su binary from package to /opt/alien/system/bin and /opt/alien/system/xbin

some applications can look for su in different locations

daywalker's picture

i see links named 'su' in both locations pointing to /usr/bin/aliendalvik-superuser-binary
should i delete the links and copy the binary itself to these locations?

coderus's picture

i dont know, i never tried with your apps. please do it yourself and tell results :)

daywalker's picture

i removed the symbolic links from 
'/opt/alien/system/bin' and '/opt/alien/system/xbin'
as you said and copied the binary from /usr/bin/aliendalvik-superuser-binary to
'/opt/alien/system/bin/su' and '/opt/alien/system/xbin/su'

permissions are set to read for all, write for root(owner) and execute for all

it still doesn't work :(

(i also tried to install busybox from aptoide store but it says basically the same thing, the su binary could not be found or the device is not rooted properly...)

EDIT: also tried this: but didn't work

EDIT2: I deleted the 2 su copies and uninstalled/reinstalled the whole aliendalvik-superuser. Then i installed android app "root checker" and everthing seems to be ok. After that i was able to install busybox. But still no success with adaway and orbot...

EDIT3: i found your twitter conversation ( and realized that the adaway version in aptoide store is only 2.2 ! So i downloaded the most recent version of adaway (2.9.2) from f-droid store and it works!

>>Now the only problem seems to be orbot which needs root access for transparent proxying through tor. ( I have the most recent version ).

LEGEND383's picture

How does one go about installing this? Googling showed nothing relating to android...

coderus's picture

what is your question about?

LEGEND383's picture

How to install this su binary rpm file on my android phone? I have been unable to find anything that even says what an rpm file is.

matemana1991's picture

I managed to install su binary on my nexus 5. Installed kernel manager but it says no root. Superuser app sees su binary. Probably some permissions problem. When it will work i'll make rpm for nexus 4 & 5 devices. I think it will work on any android device :)