Your rating: None Average: 5 (6 votes)

The sailfish-wlan-keyboard provides an easy way to use you your computer keyboard to type on your phone.

Simply connect your phone to WIFI or USB and browse a website on your computer published by your phone. Keystrokes being entered there are transmitted to your phone and inserted at your cursor position. No hassle any longer with tiny smartphone keyboards or just too big fingers.

Release 0.4.x is only compatible with version >= 0.2 of the headless keyboard extension.
Thus update the headless-keyboard as well:

For questions or bug reports, file an issue here:


Application versions: 
File harbour-wlan-keyboard-0.3.0-1.armv7hl.rpm3.24 MB13/05/2015 - 02:21
File harbour-wlan-keyboard-0.3.1-1.armv7hl.rpm3.24 MB13/05/2015 - 22:20
File harbour-wlan-keyboard-0.3.2-1.armv7hl.rpm3.24 MB31/05/2015 - 14:29
File harbour-wlan-keyboard-0.4.0-1.armv7hl.rpm3.26 MB21/09/2015 - 23:28
File harbour-wlan-keyboard-0.4.1-1.armv7hl.rpm3.43 MB22/09/2015 - 17:57

* Sat Feb 21 2015 Andrin Bertschi  0.1

- Initial version


* Sun May 10 2015 Andrin Bertschi 0.3.0

- all new design for Qml UI

- introduce two keyModes: Clipboard and Headless

- add support for the headless-keyboard-layout

- add react.js web frontend


* Sun May 13 2015 Andrin Bertschi 0.3.1

- add Swedish translations

- add Chinese Simplified translations


* Sun May 30 2015 Andrin Bertschi 0.3.2

- Fix issue in clipboard mode to set new keystrokes correctly in clipboard


* Mon Sep 21 2015 Andrin Bertschi 0.4.0

- add option to sync phone clipboard with computer

- change cover page

- add server animations

- headless keyboard mode can be used with any installed keyboard layout


* Tue Sep 22 2015 Andrin Bertschi 0.4.1

- add headless keyboard detection

- disable feature to access phone clipboard if headless keyboard not installed



MoritzJT's picture

Is it possible that it conflicts with the installed TOHKBD daemon? I cannot use it, not the clipboard mode, nor the headless keyboard mode (yes installed). Especially with headless keyboard not taking away a VKB slot in the list, I was keen on using this one.

Has the special chars support increased?


abertschi's picture

Did clipboard mode work before you installed the headless keyboard extension?

Is the web frontend browsable if the server is running and can the socket connection be estabilished? 

If you ssh as root onto your device and capture the output of 'journalctl -f' while using the app, what does it show?

Further what does 'dbus-monitor --session' logged in as user nemo show while sending keystrokes to the applications?

I don't have any TOHKBD to verify any incompatibility. I glanced at their source code ( They do provide an alternative keyboard layout which should not correlate with my patches. Further investigations would have to be made here though. A possible conflict could only be associated if the headless keyboard extension is installed.

For reasons that are still unclear, the clipboard sometimes crashes and can only be reused if the phone is restarted. 

Yes, Unicode chars are supported now.

MoritzJT's picture

This is going to be complicated to track down. It seems there could be multiple culprits: Dolphin Keyboard, Send to Phone, TOHKBD They all seem to modify some system files instead of just adding own stuff.Now I tried to uninstall headless keyboard and ran into issues:


output during successful usage attempt during clipboard mode this time:

At the end, I tried headless again without success. for the dbus stuff

There might be a fix for the clipboard crash by using pbcopy afaik:

Thanks for Unicode support! Is the headless mode also sending enter as enter stroke so I can send stuff in whatsup e.g.? Because in clipboard mode it is used to set the clipboard instead of doing it realtime :P

Thanks for your time!

abertschi's picture

Did you manage to solve the issue? I don't see any problem in the logs. Did you try to deinstall the other keyboards ie TOHKBD to check any incompability? Currently, a KEY_RETURN so a line break not an acual ENTER key is sent. Feel free to file an feature request so we can consider it in an upcoming release :)

abertschi's picture

As for the problem to uninstall the headless keyboard extension:
- The openrepos installer app is blocking the uninstallation of the application (the extension applies a patch which is undone during deinstallation. Openrepos seems to block unreversions of patches per default). Did you install the app through the openrepos installer or through manual file download and installation? If you did the later one, just press and hold on the icon on homescreen and remove the app this way. If you used the former method, reinstall the headless keyboard extension again by opening the sailfish-wlan-keyboard app, navigating to configuration/headless-mode  and pressing the download button to download the latest *.rpm file of the extension. After reinstalled, remove the application as described above by press and holding the icon for removal.

abertschi's picture

Version 0.4.1 released

objectifnul's picture

Working OK in clipboard mode. Doesn't work in headless mode (Äijänpäivänjärvi, using wifi only, keyboard set to French)

PS: I replaced "Enterd your text" with "Enter your text" in \usr\share\harbour-wlan-keyboard\publish\js\bundle.js (line 146)

fravaccaro's picture

I was diggin into it cause I planned to make a video tutorial for my blog, but I discovered that the keyboard doesn't not display accented characters.

In particular, I have a Mint 17.1 machine and my kb layout is set to Italian. The characters not displayed are èòàù and £ €.

abertschi's picture

@fravaccaro, other characters than used in the us keyboard/ language seem indeed not yet fully supported and tested. Feel free to file an issue here

So I will be considering a fix in an upcoming version and we can track further topics regarding this particular fix there. Thanks

abertschi's picture
rob_k's picture

Hi abertschi, I love this app! Thank you!

For me the clipboard mode is not working any more: only the last two characters are being stored on the clipboard, all text before is gone.

I installed the headless mode as well. It seems to work, although it is slow sometimes. Have not tested it thoroughly. There was a character missing, right at the point where it was slow. Did I make a typo or was it lost?

Cheers, Rob


abertschi's picture

@rob_k, I am glad you like the app.

There is a known issue with the app in clipboard mode, see

Further updates regarding the fix will be discussed there.
Have a good one, abertschi

rob_k's picture

Yeah, it works again!

Thank you, Rob

Mariusmssj's picture

Love it!