share-plugin-telepathy

Rating: 
4.833335
Your rating: None Average: 4.8 (6 votes)

Share plugin to send images to xmpp/jabber contacts using telepathy filetransfer.

Repository and bugtracker on Github

Homepage

Application versions: 
AttachmentSizeDate
File share-plugin-telepathy-0.4-1.armv7hl.rpm39.82 KB04/05/2020 - 23:35
File share-plugin-telepathy-0.4-1.i486.rpm707.49 KB22/05/2020 - 13:45
File share-plugin-telepathy-0.3-3.armv7hl.rpm707.47 KB24/02/2019 - 17:36
Changelog: 

0.4-1

  • Adapt API change which broke the contact list

Comments

explit's picture

Please build also for i486

noonien's picture

Done

predator2019's picture

Hi noonien. Thanx for the update. I can choose the recipient but the image is not sent. Browser links and other stuff isn't at all. The icon in the share menu is still missing.

noonien's picture

Do you have telepathy-gabble-plus installed?

Try


  mc-tool update gabble/jabber/jabber_1 bool:force-httpupload=true

because traditional filetransfer almost always fails.

predator2019's picture

Yes i installed telepathy-gabble-plus as well. But the issue still remains. With mc-tool i get

mc-tool: couldn't load account 'gabble/jabber/jabber_1': Method "GetAll" with signature "s" on interface "org.freedesktop.DBus.Properties" doesn't exist

 

Hm, strange.

noonien's picture

Your account might have another name. You will find it with:

mc-tool list
predator2019's picture

Yes that was the issue. And after installing both plugins i forgot to restart the device. Now it works! Thank You so much!

noonien's picture

Thanks for the hint, I also forgot about a reboot :-)

HoSnoopy's picture

I installed it but I cannot find any possibility to send. Where I can find it? 
Using SailfishOS on a Motorola G2 "Thea" device witth SFOS 3.2.1.20

noonien's picture

When using the gallery, it should appear in the share list next to Email, Bluetooth, MMS.

predator2019's picture

Hello. It's still not working (now on 3.3.0.16). When tap on the telepathy share (has no icon at all) a blank page pops up saying "could not load page". Has any one the same experience? Any idea or solution?

noonien's picture

You might start jolla-gallery from a terminal while trying to share and check for some relevant output.

Karry's picture

It prints this error:

file:///usr/lib/qt5/qml/Sailfish/Silica/PageStack.qml:807: Error: Error while loading page: file:///usr/share/nemo-transferengine/plugins/ShareTelepathyList.qml:82 Cannot assign to non-existent property "deleteOnlyContextMenu"
noonien's picture

Thank you both! Please update to 0.4-1 which should work again.