metasploit

Rating: 
5
Your rating: None Average: 5 (3 votes)

The Metasploit Framework is a development platform for creating security
tools and exploits. The framework is used by network security professionals to
perform penetration tests, system administrators to verify patch
installations, product vendors to perform regression testing, and
security researchers world-wide. The framework is written in the Ruby programming
language and includes components written in C and assembler.

Application versions: 
AttachmentSizeDate
metasploit-4.10.0-10.28.1.jolla_.armv7hl.rpm22.74 MB13/08/2014 - 21:54
Changelog: 

(none)

Comments

NielDK's picture

Needs glibc.

I will add that as a dependency

vadd's picture

so there will be an update???

vadd's picture

it can't be installed because it requires libc.so and I can't found it

shanti's picture

i tired devel-su pkcon install glibc-devel

but still complains .. i read this could happen if x86 binaries mixup within arm-packages 

on libc.so: on my xperia there are at least 10 versions

[root@Sailfish nemo]# ls -la `find / |grep libc.so `
lrwxrwxrwx 1 root root      12 Oct 11 08:44 /lib/libc.so.6 -> libc-2.19.so
lrwxrwxrwx 1 root root      12 Oct 11 08:44 /opt/alien/lib/libc.so.6 -> libc-2.19.so
-rwxr-xr-x 1 root root  371512 Oct 23 14:51 /opt/alien/system/lib/libc.so
-rw-r--r-- 1 root root  680348 Oct 11 07:06 /opt/alien/system_jolla/lib/libc.so
-rw-r--r-- 1 root root 1033280 Oct 11 07:06 /opt/alien/system_jolla/lib64/libc.so
-rw-r--r-- 1 root root     249 Jul 14 14:34 /opt/alien/usr/lib/libc.so
-rw-r--r-- 1 root root  680424 Oct 11 04:37 /opt/alien/usr/libexec/droid-hybris/system/lib/libc.so
-rw-r--r-- 1 root root 1033240 Oct 11 04:37 /opt/alien/usr/libexec/droid-hybris/system/lib64/libc.so
-rw-r--r-- 1 root root  680348 Oct 11 07:06 /system/lib/libc.so
-rw-r--r-- 1 root root 1033280 Oct 11 07:06 /system/lib64/libc.so
-rw-r--r-- 1 root root     249 Jul 14 14:34 /usr/lib/libc.so
-rw-r--r-- 1 root root  680424 Oct 11 04:37 /usr/libexec/droid-hybris/system/lib/libc.so
-rw-r--r-- 1 root root 1033240 Oct 11 04:37 /usr/libexec/droid-hybris/system/lib64/libc.so
shellkr's picture

It complains over a missing libc.so and can therefor not install..

jberezhnoy's picture

probably need to add

#include <time.h>

 

and rebuild the package. But I do not know how to do this (