Patch: Silica Flat Ui

Rating: 
4.875
Your rating: None Average: 4.9 (8 votes)

DISABLE THE PATCH BEFORE UPDATE

 

Summary

This patch flattens the glass items in Sailfish Silica components for those who love flat ui. This patch is only made for Sailfish 1.1.4.28 or above only. Keep in mind that un-apply the patch before you update it.

 

If you find any bugs or have suggestions, please leave your comments below and I will try hard to improve it.

 

Issue

I had uploaded a wrong and buggy version ( 1.1.0 ) before, please use this backup to restore the default ui and update to the new version ( 1.4.0 ) of patch.

 

Donations

 

Paypal : https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=XWZEYXJYWQ8UU

 

Thanks

Coderus

SK_WORK

Application versions: 
AttachmentSizeDate
patch-silica-flat-ui-1.4-6.armv7hl.rpm6.28 KB06/05/2015 - 09:39
patch-silica-flat-ui-1.4-8.armv7hl.rpm6.45 KB02/06/2015 - 13:18
Changelog: 

1.4.8 UPDATE ( 03 / 06 / 2015 )

- Fixed the ugly, white, big PageStackGlassIndicator

 

1.4.6 UPDATE ( 05 / 05 / 2015 )

- Updated for 1.1.4.28 or above

 

1.4.2 UPDATE ( 18 / 03 / 2015 )

- Fixed the "TextSwitch.qml" doesn't glow when enabled

 

1.4.0 UPDATE ( 18 / 03 / 2015 )

- Initial release

Comments

alfatuma's picture

It dosn't work on Sailfish 2.0.4.14!

malibu's picture

I hope to see an 1.1.9 adaptation, it was an amazing patch.

J0114sailor's picture

hey! are you planning to do this in 1.9.x/2.0? Because i see few spots (like those page indicators) where sre those old, not flat things. thanks!

Mystery47's picture

Great patch.
*Corner dots are too big. Really annoying looking.
*Simple small dots are nice.

Keep up good work.

saberaltria's picture

Yup, I will update soon. That is a bug. :)

saberaltria's picture

Yup, Fixed :P

danfin's picture

great patch, but the 'half dots' appear a bit large, so they cover text. C of 'Cancel', or e of 'Save' gets covered. Might be better use inverse half dots, or bars, to keep text complete.

malibu's picture

Amazing .. ! Just open browser for comment here to say this patch was really missing since i updated the Jolla.
But update is already published ! Great work ! And thanks again about this UI ..

 

caprico's picture

Thanks for updating the in my opinion, most beuatiful UI choice for Sailfish OS!

But the page indicator icon (top left and/or right side in app window) got replaced with a huge white icon with 3 dots. Is that intended? It overlaps content and looks out of place.

malibu's picture

+1 .. It's not really nice, and it's hiding some text in conversation.
By the way, i guess the selector in pulley menu changed too, i found the first was really cool :P

( But it still best than original UI ;) )

 

heubergen's picture

@Dev, you find here a Image that should clearly the bug:

Link

aQUICK1's picture

Hello  there,  i  was curious if this patch is now working on latest SF u13?

saberaltria's picture

Just updated. It should work now :)

saberaltria's picture

The answer should be 'No'. I will update it soon.

heubergen's picture

Doens't work with the newest update 1.1.4.28 :(

 

Edit: Works for me with newest update, thanks.

aQUICK1's picture

Any update of ur  patch  regarding latest version Sailfish? opt-in update  ,  would  be  great to  see it  working  again on my  jolla,nice  work,  greetz.

Prinsessa's picture

I really like this patch. Could you consider changing the buttons? I'd love to see a thin line that replaces the common SailfishOS style ribbon.

See the line under "Check for updates" and "Uninstall"

 

saberaltria's picture

Yup, I love this design, too. I will add that line in next version. :P

malibu's picture

Thanks, very great patch, love it !
Will you do another ui in another patch ? :D

saberaltria's picture

Sure. but not sure what theme style is suitable for Jolla :(

olpe's picture

Nice patch!
What about making the pulley menu thing a bit smaller? Now it takes quite many pixels of the view.

Mariusmssj's picture

Very cool patch, makes the whole UI feel completely different

 

breakdaufnk's picture

Wonderful patch!

I would like to report that new sms messages are still indicated by the old marker. Also, the activated and deactivated states of the "circles" in various settings look almost the same - too small differences in color.

Thank you again :)!

saberaltria's picture

Yup, I will try to fix it. Thz for your report!

heubergen's picture

Thank you very match for this great patch!

I can confirm that ti works for me on 1.1.2.16 and also with the Eventsview controls patch.

 

Edit: Could I please have your paypay mail-adresse? I would donate you more that just 10 hk-dollars :)

saberaltria's picture

Just updated to fix the textSwitch issue. My paypal account is saberaltria@outlook.com. I am glad to have your support. Thank you very much. :)

ssahla's picture

Thanks, now it works – and it does look nice!

 

Couple of things though:

  • Toggles in settings always seem to be off, no matter what the state really is. For example, Settings > Sounds > Silence sounds flashes briefly when I tap on it, but always returns to the off state. (The setting really changes, but the symbol doesn't reflect that.)
  • Unread emails in Mail app ("unread tag" half visible on the left) still have the old look.
ssahla's picture

Looks great in the screenshots, but doesn't work for me (Sailfish 1.1.2.16). I installed, applied the patch in Patchmanager and restarted preloaded services. What happened:

- UI elements' appearance was not changed (the tweak did not work)

- Toggles disappeared from the Settings front page

- Patchmanager settings plugin didn't open anymore, so I couldn't unapply patch

Managed to get my system back to normal by running this in terminal:

devel-su patch -R -p 1 -d / -i /var/lib/patchmanager/ausmt/patches/silica-flat-ui/unified_diff.patch

 

saberaltria's picture

I am so sorry about that since I have uploaded a wrong patch and it will make patchmanager unable to unapply the patch. I have uploaded the original files just now, please use that to restore the system files and update my patch and re-apply it, then everything should be fine. Sorry for my mistake once again :(