Prepatch Patch: Keyboard-Swipe

Rating: 
4
Your rating: None Average: 4 (4 votes)

A prepatch patch which allows you to move the cursor by swiping on the keyboard.

This requires prepatch to be installed. Please read the prepatch-tmo-post before installing as there might be some issues that you don't want.

This patch has only been tested on  2.1.4.14. If you use an older version either use my old patchmanager-patch or follow the instructions in the comments.

    Application versions: 
    Changelog: 

    (none)

    Comments

    levone1's picture

    Really would love this, especially since the '<>' keyboards i have so far are a bit buggy... Issue I'm having is that after applying the patch and rebooting, the swipe-to-move-cursor works great, but the keyboard doesn't work anymore, (no response with typing, space, etc), but swiping to move the cursor is all that it does.  I am using a Sailfish port, (Xperia X Compact), so maybe that's the problem... Any ideas? Thanks

    jakibaki's picture

    The keyboard is working without problem for me.

    Are you on current sfos? (2.1.4.14) If not update if possible or replace /usr/share/prepatch/050-prepatch-keyboard-swipe/usr/share/maliit/plugins/com/jolla/KeyboardBase.qml.patch with this one (https://pastebin.com/e1CmC9F8). 

    The pastebin is just my old version (which was originally made for patchmanager) but it should also work with prepatch.

    levone1's picture

    Tried it out but no go... Changed .qml.patch file and rebooted, and keyboard works now, but swipe doesn't move cursor...Maybe some way to install with Patchmanager instead? 

    update - copied older version linked in description to /usr/share/patchmanager/.../kbswipe, (I created the folder), and set permissions 644 and added json file, and rebooted. Patch shows up in Settings> patchmanager, and successfully applies, but no functional cursor movement. Keyboard wotks fine.Tried reboot...I'm new to sfos, (coming from Android), so not sure how logs work. If there's some equivalent to logcat that would help, let me know...

    jakibaki's picture

    You don't have to manually copy my old version into patchmanager. The old version is availible in the patchmanager-web-store: https://coderus.openrepos.net/pm2/project/sailfishos-patch-keyboard-swip...

    You can install it directly from the patchmanager settings page.

    oxygenh's picture

    I tried it, but i get "Failed to install patch" message. :( Unfortunally i installed   "Prepatch Patch - keyboard swipe" early, bit uninstalled it before this patch.

    levone1's picture

    Ok, got it working. Sorry, i didn't see any way to install a .patch file, (or any file), through patchmanager settings, but i deleted my manually installed one, and used 'patch >' command in terminal. Now I've got working keyboard and swipe cursor. Thanks. However, not working in every situation. .. Typing this, for example, no cursor swipe action, but typing in search field, for example, it's working..
    edit- sorry again, I was testing while using an Android browser.browser. Working great on Sailfish browser. Thanks again ...

    levone1's picture

    Thanks, I'll try it. My version is 2.1.3.7, (I think the only one so far for Xc...)