The Mutt E-Mail Client

Rating: 
5
Your rating: None Average: 5 (5 votes)

 Mutt is a small but very powerful text-based mail client for Unix operating systems.

Some of Mutt's features include:

  •     color support
  •     message threading
  •     MIME support (including RFC2047 support for encoded headers)
  •     PGP/MIME (RFC2015)
  •     various features to support mailing lists, including list-reply
  •     active development community
  •     IMAP support
  •     full control of message headers when composing
  •     support for multiple mailbox formats (mbox, MMDF, MH, maildir)
  •     highly customizable, including keybindings and macros
  •     change configuration automatically based on recipients, current folder, etc.
  •     searches using regular expressions, including an internal pattern matching language
  •     Delivery Status Notification (DSN) support
  •     postpone message composition indefinetly for later recall
  •     easily include attachments when composing, even from the command line
  •     ability to specify alternate addresses for recognition of mail forwarded from other accounts, with ability to set the From: headers on replies/etc. accordingly
  •     multiple message tagging
  •     reply to or forward multiple messages at once
  •     .mailrc style configuration files
  •     easy to install (uses GNU autoconf)
  •     compiles against either curses/ncurses or S-lang
  •     translation into at least 20 languages
  •     small and efficient
  •     It's free! (no cost and GPL'ed)

http://muttrcbuilder.org/ is useful to create .muttrc configuration files.

This build supports IMAP accounts, GPG and SMTP.

KRB5, GPGme and Cyrus-SASL are required as dependencies.

For GPG encryption GnuPG Pinentry should also be installed.

Application versions: 
AttachmentSizeDate
File mutt-1.5.23-2.armv7hl.rpm2.11 MB11/06/2014 - 20:34
Changelog: 

mutt-1.5.23-2: fixed GPGme dependency issue.

mutt-1.5.23-1: Initial build.

Comments

inte's picture

I guess I should try to rebuild a current version once I get my GeminiPDA running again. Sorry, haven't used mutt myself for ages...

dyraig's picture

Unfortunately, this package can no longer be installed on newer versions of SailfishOS, due to a lack of libssl.so.10 and libidn.so.11. It would be great if this could be rebuilt for newer versions.

lpr's picture

possible workaround: create symlinks of the old required libraries to the new ones available in new SFOS versions.

working workaround for openssl: install https://openrepos.net/content/lpra7/openssl-102-legacy-jollaphone-x-xa2

dyraig's picture

I did try installing that older openssl-version in parallel, and that's how I discovered that libidn was also missing. Unfortunately, libidn got removed completely in 4.1(? - don't remember, could've been 4.0) according to the release notes, so there isn't even a newer version.

lpr's picture

ok, I uploaded jollas libidn rpms:
https://openrepos.net/sites/default/files/packages/7598/libidn-1.23-1.3....
https://openrepos.net/sites/default/files/packages/7598/libidn-locale-1....

if they just got removed in SFOS4.1, they can be installed again...

dfstorm's picture

"very active communauty"... Last updated a while ago tho ;)

NikosAlexandris's picture

'gpgme' is missing, still. Is there an update required?

NikosAlexandris's picture

Done, apologies for the noise. Solution clearly provided at https://together.jolla.com/question/887/gpg-for-email-and-other-stuff/?c...

SebMa's picture

Hi,

Can you please add the "--enable-hcache" to your build script so that mutt handles the "header_cache" variable:
Error in /home/nemo/.mutt/muttrc, line 9: header_cache: unknown variable
source: errors in /home/nemo/.mutt/muttrc

?

kfs7's picture

Great job.

Is it possible to implement:

trash: unknown variable      -- this is a neomutt patch AFIK

xterm_set_titles: unknown variable  -- this comes comes handy when ssh into sailfish from another pc when yours is not available.

max630's picture

Very nice, but why header_cache is disabled?

kaulian's picture

Thanks, but i can't install it.

I have this error "nothing provides libgpgme.so.11"

 

inte's picture

You need the (official) gpgme.

Make a

pkcon install gpgme

and try again.

EDIT:

The current release should resolve the required dependencies automatically. No further action required from your side anymore!

 

kaulian's picture

Same problem... :(

It's seems the repository missing

inte's picture

You need to activate the mer-tools repository:

$ devel-su
# ssu ar mer-tools
# ssu ur
$ pkcon refresh

Alternatively, you could also download gpgme directely from here:

http://releases.sailfishos.org/sdk/latest/mer-tools/builds/armv7hl/packages/armv7hl/gpgme-1.2.0-1.1.1.armv7hl.rpm

Sorry for the inconvenience, I might load up a more recent gpgme soon.

In the meantime, please use the solution above.

objectifnul's picture

404 not found

kaulian's picture

It's GOOD :)

inte's picture

GREAT! :) Thank you for the feedback!