N9 RepoMirror

Rating: 
4.764705
Your rating: None Average: 4.8 (17 votes)

NO WARRANTLY, IT MAY DOESN'T WORK PROPERLY ON YOUR DEVICE, IF SO - YOU SHOULD REFLASH YOUR DEVICE!

Actual n9repomirror.list which contains the following repositories:

1) https://coderus.openrepos.net/n9mirror/ (instead dead Nokia-repositories)

2) http://mirror.thecust.net/harmattan-dev.nokia.com/

Default obsolete Nokia repositories will be disabled.

This will allow you to enable developer-mode after phone flashing (reset) etc.

Thanks to CODeRUS and basil_s for support!

Keywords:

Application versions: 
AttachmentSizeDate
n9repomirror_0.7.2_armel.deb13.16 KB14/10/2015 - 21:41
n9repomirror_0.6.0_armel.deb13.14 KB26/05/2015 - 11:23
Changelog: 

0.7.2: Regions script update
0.7.1: All regions support (need test!)
0.6.0: Disable sdk repository by default
0.5.0: Enable repository mirrors and disable obsolete Nokia repositories.

Comments

lenin2089's picture

репозиторий coderus перестал быть активным.

Ancelad's picture

Сайт на ремонте 

alejandro77's picture

Hi, please can someone explain me how to use the mirror from the beginning?

I have a n9 is that they gave me and according to what little I've been researching I need to install install the mirror to achieve developer.

  I have already installed FileBox, must resetiar the phone?

Ancelad's picture

Just try to install N9RepoMirror and enable developer-mode

ProzacR's picture

Recently installed this on my N9, then I was able to set developer mode and acess phone terminal. All went fine. Thanks. ;)

Caderno's picture

lease I can not install developer mode, the error saying "it is not possible to trace." I managed to install the normal a few days ago. Now when I put "flasher" does not install, my version is 005

sorry for any error, I am using google translator

please help me as fast as possible.

Caderno's picture

OK FOLKS I FIND (MAYBE) SOLUTION. When I was about to give up everything and play the nokia n9 in the trash (no joke), I wanted to try one last time to install developer mode. It was then I installed (i dont know way) Nokia link program. Anyway, he installed good and when I look at my phone came four pedentes updates. Anyway, guys are in my worked try in you, download and install the program NOKIA LINK...

Caderno's picture

PRA QUEM É BR

 

OK GALERA EU ENCONTREI (TALVEZ) A SOLUÇÃO. Quando eu já estava para desistir de tudo e jogar o nokia n9 no lixo (não é piada), quis tentar pela ultima vez instalar modo desenvolvedor. Foi ai que instalei (i dont know way) o programa Nokia link. Enfim, instalei ele de boa e quando fui olhar meu smartphone apareceu quatro atualizações pedentes. Enfim, galera se no meu deu certo tentem no de vocês, baixe e instale o programa NOKIA LINK.

Nikolai's picture

please help can not insta n9repomirror
BusyBox v1.20.0.git (MeeGo 3:1.20-0.2+0m8) built-in shell (ash)
Enter 'help' for a list of built-in commands.

~ # cd /home/user/MyDocs
/home/user/MyDocs # dpkg-i n9repomirror_0.7.2_a
rmel.deb
sh: dpkg-i: not found
/home/user/MyDocs # dpkg -i n9repomirror_0.7.2_
armel.deb
file /var/lib/dpkg/tmp.ci/digsigsums cannot beopened
No digsigsums file
Выбор ранее не выбранного пакета n9repomirror.
(Чтение базы данных ... на данный момент установлено 52386 файлов и каталогов.)
Распаковывается пакет n9repomirror (из файла n9repomirror_0.7.2_armel.deb)...
Package n9repomirror: File '/var/lib/dpkg/info/n9repomirror.postinst' not in digsigsums -- warning
No digsigsums file
Настраивается пакет n9repomirror (0.7.2) ...
Remove all default offline repositories
/var/lib/dpkg/info/n9repomirror.postinst: line8: can't create /etc/apt/sources.list.d/aegis.ssu-keyring-001.list: Permission denied
dpkg: не удалось обработать параметр n9repomirror (--install):
подпроцесс установлен сценарий post-installation возвратил код ошибки 2
При обработке следующих пакетов произошли ошибки:
n9repomirror
aegis-installing n9repomirror (from 'com.nokia.maemo/net.openrepos.harmattan')
/home/user/MyDocs #

Starr4Ever's picture

Issue:  Only 0.6.0 successful install but still cannot enable developer mode .

 

Background:  Black N9 64GB (product 059J228, Middle East) running 40.2012.21-3_PR_006. Never been in developer mode. Works fine in all respects, used with a Mirrorlink enabled Alpine ICS-X8 car stereo and Nokia Car Mode app for 3 years. Can no longer obtain Nokia Car Mode so I'd rather not reflash N9.

 

Detail:

 

-  0.7.2 fail install with “Interrupted” message. Other packages (myExplorer) download and install OK from openrepos.net.  3rd party sources enabled. Several reboots, no difference. 

 

-  0.6.0 installed OK. Listed under Settings —> Applications —>Manage Applications. No error symbols or warnings to suggest it was damaged or partially installed. However, cannot enable developer mode. I accept the Dependency Notice to download 2.2MB but after 2 seconds it pops up the error “Download failed - Can’t complete the download. Connection to the application provider was lost. Try again later”. I retry several times and no luck. Same after several reboots and same after doling the Check for Updates under Manage Applications.

 

The Update Check always passes with “Device is up-to-date”. I ran wireshark trace on my router and confirm ~230 packets exchanged on every check. Each check involves a number of DNS queries:

 

- downloads.maemo.nokia.com.  FAILS.

- coderus.openrepos.net.  PASS. 46.39.225.253

- p.d.ovi.com. FAIL.

- harmattan.openrepos.net. PASS 88.198.208.108. Then does a GET on /basil/dists/personal/release

 

Whenever I try to enable Developer Mode the packet capture count never increments when it reports “Download failed”. Not one single IP packet.  It does not appear to start a connection to any server.

 

Following files are in /etc/apt/sources.list.d, 

 

aegis.ssu-keyring-001.list  (0 bytes)

aegis.ssu-keyring-006.list  (0 bytes) <— 006 matches my N9 model

aegis.ssu-keyring-299.list (222 bytes) <— this contains the broken server URLs pointing to downloads.maemo.nokia.com/harmattan/299, /apps & /tools.

n9repomirror.list (480 bytes) 

openrepos-basil.list (87 bytes)

osa.list (22 bytes)

 

I see N9 RepoMirror postinst script tries to clear the contents of the list files. I assume that is why aegis.ssu-keyring-001.list and aegis.ssu-keyring-006.list show as empty. But for some reason it was unable to do the same for aegis.ssu-keyring-299.list. [I’m curious why  aegis.ssu-keyring-299.list is appearing on a 006 variant N9 ? mmm.. I once owned a cyan N9 16GB (product 059L694, Australia) running 40.2012.21-3.299.1_PR_299 and while I had both N9 I sometimes swapped the sim trays (quicker than popping out the sim). And both N9 were backed up using the same instance of Nokia Suite.]

 

Anyway, I changed postinst script and repacked it. 

 

#!/bin/sh

 

echo Remove all default offline repositories

: > /etc/apt/sources.list.d/aegis.ssu-keyring-299.list

echo Done

 

exit 0

 

0.6.0 continues to install OK with modified script above but unfortunately still never clears the 299 list file. Still 222 bytes. I know the script runs because I can create any new file of 0 bytes e.g. aegis.ssu-keyring-300.list. But for some reason contents of aegis.ssu-keyring-299.list refuse to be cleared. I am really not sure if the 299 file is the cause of the “Download failed” error, just a lead from reading the forums. I also read that some people reflashed to get developer mode working. 

 

Any suggestions or script command to try ?  Again, I can’t reflash as I will lose the Nokia Car Mode app (I have searched everywhere and cannot find an archive of Nokia Car Mode to reinstall).

 

Thanks

 

Ancelad's picture

 Version 0.7.2 should destroy ALL aegis.ssu-keyring files. As I see you have unexpected 299-file. Maybe it has wrong properties and can't be changed without root-credentials. Try this trick =)

Starr4Ever's picture

 

Thanks Ancelad for the tip. 

It did sound promising but unfortunatelty I still get access denied after choosing "Yes to All" on the file replace operation. (replace aegis.ssu-keyring-299.list Size: 222 bytes Modified: Mon April 15 16:34:54 2013 with Size: 0 bytes Modified: Tue Mar 1 08:09:24 2016 ? replied "Yes to All"). I would upload screenshot but I dont know how to add image to this post.  

[On a side, strange the timestamp shows March 1. It is not yet March 1 here (Australia). The time in settings showed 21:09 Feb 29 with timezone Melbourne GMT +11 but the filesystem is adding 11 hours to 21:09 to result in Mar 1 08:09.  Filesystem is incorrectly adding an extra 11 hours to file attributes modifed date. Sim is another phone right now and time is manual set.]

I tried same approach on other aegis list files 001 and 006 in /etc/apt/sources.list.d and got the same access denied error. I'm not sure if errors are related to incorrect time on files.

Ancelad's picture

I have another decision - you can mount your partitions into Linux, so you will have full access to your filesystem. But you will get "Warranty message" because your phone will turn into open-mode.

Starr4Ever's picture

I put the sim in N9 and let  the time auto sync from the cellular network. But I still see timestamps on any files exactly 11 hours greater than synced time. Something wrong with how GMT offset is applied in filesystem.  So I changed back to manual time and selected UK timezone (GMT 0) instead of Mebourne (+11), so now timestamp issue gone since we no longer have any GMT offset, but still cannot zeroize or overwrite the 299 file with your trick or script. Something different about that 299 file, I don't even know how it got there. I then uninstalled 0.6.0, rebooted and run your 0.7.2 deb. Like before 0.7.2 failed with interrupted error, but your script does actually change the timestamp on both my 001 and 006 aegis list files, so I know it is successfully destroying contents of 001 & 006 but the 299 file is (for unknown reason) stuck on 2013 timestamp and 222 bytes. Assume it is access denied or some sort of lock.

Does the conversion to open-mode require a reflash and loss of existing apps ? If yes I will need to decline as I really cannot lose Nokia Car Mode app. So I guess the worst case is my N9 cannot use Warehouse to install apps. I can survive with that on this N9 as I have mostly what I need already installed, I was just keen to install your SailfishOS theme.  If I can mount partition in Linux with full r/w access and not lose my installed apps that would be great! Any instructions or not possible to preserve apps ? Thanks Ancelad.

 

Ancelad's picture

Going to openmode is safety in most cases, you even don't need to flash anything, because mount-process requires kernel LOAD, not FLASHING, so you will not lose any data (if process is done correctly).

Openmode has three issues:

1) Devicelock doesn't work (but there is decision)

2) Apps installing-process may be crashed sometimes, not critical

3) Warrantly note during phone-loading, only one way to remove it if you got it - reflash

Here is tutorial. You need A and B (from 1 to 5). Good luck. I've done it some times without any accidients.

 

Starr4Ever's picture

Thanks Ancelad. I was able to convert to open-mode with flasher and yes I see the warranty warning, no problem. But when I check partitions I only see two out of three N9 partitions. Same on Win 7 or OS X 10.10.

df -k

...
/dev/disk2s1 56328960 34257472 22071488 61% 0 0 100% /Volumes/Nokia N9
/dev/disk2s3 2097152 522348 1574804 25% 0 0 100% /Volumes/Untitled

"Nokia N9" is MyDocs (53.72GB).
"Untitled" is /home/usr (1.97GB).

The System volume partition which is 4GB does not appear. I don't know why. On both Win7 and OS X I have loaded Paragon extension. In OS X Disk Utility the Partition Layout screen reports disk as "Linux 2. Linux 2.6.32.201 Media" with first partition "Nokia N9" (53GB), then 4.29GB of empty space, then "Untitled" (2GB). System volume shows as Free Space. :(

After unplug the N9 fully boots OK and apps are intact. Of course I would still like to destroy the 299 file and enable developer mode. I an thinking of getting a Linux PC setup to see if that helps. Thanks again.

=== UPDATE ===

Fixed!

Summary: Now in Developer Mode which allowed me to install Warehouse Installer, Warehouse and then SailfishOS Theme for Harmattan. Love the theme. And I never lost an app. Thanks again Ancelad!

Detail: Ran Ubuntu 11.10 from a CD. In Ubuntu Disk Utility I could see /dev/sdc2 partition (4GB rootfs) was at least recognised as a valid partition (vs just free space in OS X). /dev/sdc2 did not auto mount so I did manual mount as /media/rootfs. Then checked properties of the bad 299 file.

-rw-r--r-- 1 29999 29999 222 2013-04015 06:34 aegis-ssu-keyring-299.list

It showed owner as 29999 whereas all other files showed owner root.

Next,

- sudo chmod 777 aegis-ssu-keyring-299.list
- sudo mv aegis-ssu-keyring-299.list aegis-ssu-keyring-299.old
- reboot
- uninstall N9 RepoMirror 0.6.0, reboot and re-install same.
- Software Update notification prompted update of N9 RepoMirror to 0.7.2. Accepted and installed OK.
- reboot again.
- enabled Developer Mode. This time success downloaded 2.2MB file.
- Installed the devicelock package to restore device lock capability in open mode.

BTW, I had errors with Warehouse Installer and Warehouse. Found answer in step 4 of https://talk.maemo.org/showpost.php?p=1455992&postcount=406.

explit's picture

Thanks you guys! Ancelad, CodeRUS, Basil and others!

After this Weekend N9repomirror not working anymore.

I have fresh reflashed Nokia N9 PR_009

First i enable Installation from Unstusted Sources in the Settings.

Then, i installed N9Repomirror 0.7.2

When trying to enable Developer Mode afterwards i get an error: can't trace packages

Tryed 2 different Internet connections. Seems, that the CodeRUS Repos are not reachable anymore.

Any ideas, how to fix this ?

 

Thanks

Ancelad's picture

All repositories work. Did you try to get updates from Applications - > Manage Applications - > Get updates icon? Also you should try to reboot your phone.

explit's picture

Thanks for the Answer Ancelad. The problem is, that i don't get the Update notofication for Maps, Twitter etc.

Tryed from the Applications - > Manage Applications - > Check for updates.
Also tryed after reboot. Yesterday, the same way worked fine, so i think this is an issue with Repos....

Ancelad's picture

There are two repo-links in description, they're active...

explit's picture

Yes, thats true. Alredy checked. In the browser they works, but my N9 doesn#t see any updates...

Maybe because i'm PR_009 ?

I checked also the contents of the /etc/apt/sources.list.d

There are 3 files:

aegis.ssu-keyring-009.list (0 bytes)

n9repomirror.lis with all correct Repos

osa.list (22 bytes)

Anything wrong here?

Is it possible to install al developermode aps without root from the filecase?

Oh... It was so simply anything with Nokia N900:

Terminal: please

Root Acess: please

SSH: No problem

Aegis Restrictions: Nada....

Where are the good times gone....

 

Pras4's picture

Maybe. I have the PR_009 too, but I try since three months to activate developer mode: http://talk.maemo.org/showthread.php?t=96018&page=5. So an apt-get update doesn't work too :(

gustavospace's picture

N9 Begins! Thanks!

screamer's picture

also on a 340 version (Denmark) & Struggling with the /etc/apt/sorces.list.d
is there some way to install FileboxRoot (like the one from the N9Qtweak)? otherwise Windows users don't have much choice in repacking the deb file...

andreasdybdahl's picture

I have PR1.3 firmware with version code 340 (Denmark). N9RepoMirror version 0.7.1 fails to install, I can't update from version 0.6.0 either. Can you help?

IDA447's picture

i installed 0.6 which worked. then i installed warehouse installer, warehouse which also worked pretty fine. but then when i wanted to update the n9repomirror to 0.71 it always fails the update any ideas guys? thank you!

ViBENo1's picture

my phone cannot install it. installation fails.

thatjournalist's picture

I just tested the app with my Malaysian N9 (region 005) and it won't install. The installer just crashes and said it was cancelled.

I'm going to flash it to region 001 to see if that works.

deixi's picture

Thank you, you saved my phone!

 

tipkovnica's picture

I have N9, freshly restarted. Problem is old Nokia repository is not working. I have found instructions to install this repomirror that will allow me to install dependency notice and developer mode. I can install repomirror no problem but when installing warehouse with warehouse installer I am stuck error cache not refreshed, when installing developer mode I have download fail. I beleive this solution is not working for freshly restarted devices anymore. Please help, N9 is useless without this. Thanks!

Pages