harbour-mattermost-sfos-2.1.3.7

Rating: 
5
Your rating: None Average: 5 (2 votes)

WARNING: Before install version 0.1.2 successfully remove old version (bacuse for 2.1.3.7 i change RPM's package name)
WARNING: This version compiled with Sailfish SDK 2.1.3.7, and incompatible with newer versions of SailfishOS, 

Mattermost - is private cloud chat. And this is a native SailfishOS client for Mattermost. 
This is early alpha version. The client is in active development.
What is done:

  • messaging in private, direct and open channel
  • receive and send files, documents and images
  • edit, delete and copy messages
  • connect to server with self-signet certificate
  • email or token authentication 
Screenshots: 
Application versions: 
AttachmentSizeDate
File harbour-mattermost-0.1.1-1.armv7hl.rpm191.24 KB01/06/2018 - 18:35
File harbour-mattermost-2_1_3_7-0.1.2-1.armv7hl.rpm208.17 KB27/06/2018 - 12:46
Changelog: 
* Wed Jun 27  2018 sashikknox <sashikknox@gmail.com> - 0.1.2-1
- add status icons for users avatars
- open messages dialog when notification activated
- fix some bugs
- fix russian translation

 * Fri Jun 1   2018 sashikknox <sashikknox@gmail.com> - 0.1.1-1
- remove depricated ImageViewr for support vie images in SailfishOS 2.2.0.29

Comments

naytsyrhc's picture

Perfect. Worked.

sashikknox's picture

hey! if you need last build of Mattermost client for Saiflish 2.1.3.7, please wrote me here? as answer.

naytsyrhc's picture

Unfortunately, this version again complains about incompatible qt versions... [F] unknown:0 - Cannot mix incompatible Qt libr
ary (version 0x50603) with this library (versio
n 0x50602)
Aborted

sashikknox's picture

yes, when i install it from Storeman, its install harbour-mattermost-0.1.2-1 ... but you need install harbour-mattermost-2_1_3_7 ... try install. from terminal
pkcon install harbour-mattermost-2_1_3_7
or
devel-su pkcon install harbour-mattermost-2_1_3_7
 

naytsyrhc's picture

Ok. Thanks.

naytsyrhc's picture

Perfect, That one works as expected!

sashikknox's picture

before update to new version, remove old,  i change packacge name because it has conflicts with version for newest sailfish os releases

sashikknox's picture

glad to hear it  )