English keyboard with arrows and numbers

Rating: 
4.6
Your rating: None Average: 4.6 (5 votes)

Alternative English layout with Left & Right arrows, Up & Down are visible in the symbols view. This is a fork of sailfish-en_ios.

Compatible with Sailfish OS 1.1.4.x Äijänpäivänjärvi and above. Activate it via Settings > System > Text input > Keyboards > English-arw and/or English-123 (for an additional row with numbers) and enable it by holding the spacebar and selecting English-arw and/or English-123. Layout with a larger spacebar available.

Build on the Jolla thanks to Schturman http://talk.maemo.org/showthread.php?t=92963.

Note: The arrows don't work in Android apps.

If you like my work, please consider to donate via Flattr or PayPal.

Screenshots: 
Application versions: 
AttachmentSizeDate
harbour-englishx-0.2.0-1.noarch.rpm13.63 KB22/10/2016 - 20:27
Changelog: 

- It should be possible to install it even on the Jolla Tablet.

Comments

olf's picture

These keyboard layouts look very nice on the screenshots, like a big enhancement of the original "English QWERTY Arrow Keyboard" (sailfish_en-ios).
But unfortunately the "English keyboard with arrows and numbers (EnglishX keyboard)" does not work under SailfishOS 2.0.4.14 (as already mentioned here):
The RPM installs nicely in Warehouse, one can activate the "English-123", "English-arw" and "EnglishX" keyboard layouts in Settings --> Text input --> Keyboards, but only "EnglishX" is selectable in the virtual keyboard.
But even the "EnglishX" keyboard layout does not work as advertised, it merely resembles Jolla's original English keyboard layout (no Arrow Keys or other extras)!
In contrast to that, the original "English QWERTY Arrow Keyboard" still works well under SailfishOS 2.0.4.14.

P.S.: I never had "Dolphin Keyboard" installed on this Jolla 1 phone, but I do still have "The Emoji Keyboard" installed.

kinggo's picture

This does not for me also. Actually, it never worked. I was hoping that update would fix that but still the same...... Selecting english-arw or english-123 does nothing. But If I enebale englishX then I can switch to englishX. But that one is the same as original english.

gedeon's picture

Hi, this is not working on Sailfish 2.0.4.14 unfortunately, the sailfish-en_ios is working, but this version keyboard would be better with numbers.

fravaccaro's picture

I can't confirm, I'm using the 2.0.4. Try to refresh my repo, install it again and reboot.

pseudoscion's picture

Likewise, I can get English-X working but when I try and change to English-123 or English-arw it does not change the keyboard. I am running 2.0.4.14 with the original Jolla 1 device. I don't have any other keyboards installed and I do not have Dolphin keyboard installed anymore although I did try it a long time ago, before removing it.

gedeon's picture

I tried to uninstall, refresh repo, reinstall, reboot and still the same. I can change to EnglishX, but it is total the same like the normal english keyboard, and I can not change to English-arw and also to the 123... I use Intex Aqua Fish with edited content (from the coderus's description), so far everything is working well, (so like Jolla C 2.0.4) except this keyboard.

fravaccaro's picture

Do you have the Dolphin keyboard installed?

gedeon's picture

No, I don't. Only this and the ios one.

fravaccaro's picture

I'll be brutally sincere and tell you I have no idea what's gone wrong. Suddenly both English-123 and arw and they didn't work, but uninstalling the package, rebooting and installing it once again made them work again. No problem on the tablet.  I'm deeply sorry for the inconvenience, but so far this is the only (empiric) procedure which seems to be effective.

gedeon's picture

I tried these again as you described, but still the same unfortunately. I can choose only the EnglishX, but it is working with the same layout like the original english keyboard without arrows or numbers and I see but I can not choose the other two, it is not changing... Any more idea?

krnlyng's picture

i am unable to enable it on 1.1.6.27 if i select English-123/English-arw after holding the spacebar nothing happens, can i provide logs?

isgursoy's picture

Forgot to unapply old version. How can I solve the issue?

Mariusmssj's picture

Brilliant :)