YTPlayer

Rating: 
4.82
Your rating: None Average: 4.8 (50 votes)

Unofficial YouTube client for Sailfish OS!

Two very important notices!

1) You must provide youtube-client-id.json and youtube-data-api-v3.key files in your Downloads folder in order to use the application. You will have to generate them yourself, and sadly It is a thing and a half to do, but you can follow this guide to generate and download the files. This may have implications to your Google account, so do this at your own risk. Once YTPlayer has started without complaining about the missing keys or files, you can delete the files from the Download folder.

2) Google restricts YouTube Data API v3 usage. I was greeted with the following message in the YTPlayer log: "We're sorry, but your computer or network may ben sending automated queries. To protect our users, we can't process your request right now." That happened to my keys during developement, I'll have to wait and see it they work after a few days of waiting.

This all means that I will soon halt developing YTPlayer, and will only provide builds of the application for new SFOS versions. Old SFOS versions are no longer supported after 0.6.18 release.

Known limitations:

  • Google restricts YouTube Data API v3 usage
  • Only 360p and 720p videos are supported
  • Some vides are available only at 360p
  • Fetching newest videos from all subscribed channels doesn't work
  • Recommened videos may not show relevant results

This version is a fork of YTPlayer by osetr, which is a fork of YTPlayer by tworaz.

Source code is available at GitHub. Pull requests and translations are welcome! Especially tweaks regarding YouTube API v3 and coping with its limitations are highly appreciated!

If you like this app and would like to support me maintaining it, you can buy my a cup of coffee!

Screenshots: 
Application versions: 
AttachmentSizeDate
File harbour-ytplayer-0.6.9-1.armv7hl.rpm273.92 KB15/09/2019 - 14:19
File harbour-ytplayer-0.6.9-1.i486.rpm295.42 KB15/09/2019 - 14:19
File harbour-ytplayer-0.6.15-1.armv7hl.rpm696.52 KB01/06/2020 - 18:38
File harbour-ytplayer-0.6.15-1.i486.rpm729.67 KB01/06/2020 - 18:38
File harbour-ytplayer-0.6.16-1.armv7hl.rpm699.91 KB11/06/2020 - 09:23
File harbour-ytplayer-0.6.16-1.i486.rpm732.38 KB11/06/2020 - 09:23
File harbour-ytplayer-0.6.17-1.aarch64.rpm1.29 MB31/01/2021 - 04:07
File harbour-ytplayer-0.6.17-1.armv7hl.rpm1.28 MB31/01/2021 - 04:07
File harbour-ytplayer-0.6.17-1.i486.rpm1.31 MB31/01/2021 - 04:07
File harbour-ytplayer-0.6.18-1.aarch64.rpm302.73 KB27/07/2021 - 21:43
File harbour-ytplayer-0.6.18-1.armv7hl.rpm293.71 KB27/07/2021 - 21:43
File harbour-ytplayer-0.6.18-1.i486.rpm327.82 KB27/07/2021 - 21:43
Changelog: 

0.6.18-1

  • Added (restore) youtube-dl update functionality in Settings
  • Read youtube-client-id.json and youtube-data-api-v3.key from Downloads
  • Improve error reporting a bit

Full change log can be found in GitHub.

Comments

direc85's picture

Using your own API keys would be great. I'll look into it! Thanks for the tip!

247's picture

Just noticed i can't subscribe to channels with the app, if i click on subscribe just nothing happens

Shervrar's picture

Right now it's not showing anything . Consider adding a way for us to use our own api keys (i think that's possible right ) please :)

MartiMasa's picture

PS: Would be happy if available in Jolla store at some point...it should be the standard YTplayer ;-)

MartiMasa's picture

Great progress, I like the refined app a lot and would be happy to donate! However, I noticed a glitch that it freezes (app completely unusable...even restart/reinstalling doesn't help) when browsing a YT channel :-( Hope you have time to check or eventually be able to fix it!

akikk88's picture

Is this app coming update jolla store? :)

akikk88's picture

But after all very good job!! Works very well with my sailfish x xperia xa2. Thank you! ☺

direc85's picture

Okay... It looks like IPv6/both on mobile broadband (DNA/Finland) breaks it. Using IP (IPv4) results in videos played flawlessly. Dang it!

direc85's picture

@akikk88 I have noticed the same thing. I have found mobile broadband being less successful than WLAN (even though I can play the same video on browser via either) on starting playback, so if possible, try it over WLAN. I'll try to figure out how to collect some useful debug information about this...

akikk88's picture

Some times shows videos, but not always..

PawelSpoon's picture

Thanks !

carmenfdezb's picture

New icon is really nice ;)

247's picture

Can't find any video too, had a look on terminal output and it says i have exceeded my quota, maybe this is useful

direc85's picture

That is correct; there seems to be a quota on the Google aggount I created. I will look into it soon (tomorrow).

247's picture

Seems i have reached my quota limit for almost everything the app can do :p but anyway don't feel in a hurry :)

TMavica's picture

Cant find any video

Serega_xDD's picture

Very Good

Historyscholar's picture

AWESOME

osetr's picture

Thank you for taking the baton :)

direc85's picture

No problem!

Pages