YTPlayer

Rating: 
4.848485
Your rating: None Average: 4.8 (33 votes)

YTPlayer is an unofficial YouTube client for SailfishOS.

This version is a fork of YTPlayer by osetr, which is a fork of YTPlayer by tworaz.

The current version is mostly just an updated build with current youtube-dl, but there are important performance fixes and many layout adjustements, too.

Source code is available at GitHub. Pull requests and translations are welcome!

Screenshots: 
Application versions: 
AttachmentSizeDate
File harbour-ytplayer-0.6.9-1.armv7hl.rpm273.92 KB15/09/2019 - 14:19
File harbour-ytplayer-0.6.9-1.i486.rpm295.42 KB15/09/2019 - 14:19
File harbour-ytplayer-0.6.10-1.armv7hl.rpm274.41 KB25/09/2019 - 01:07
File harbour-ytplayer-0.6.10-1.i486.rpm295.72 KB25/09/2019 - 01:07
Changelog: 

0.6.10-1

  • Update Chinise translation
  • Use .yaml file to generate .spec
  • Use git head revision in About page

0.6.9-1

  • Remove unused 1080p menu element

0.6.8-1

  • Fix updating youtube-dl
  • Use internal log when updating youtube-dl
  • Better propagate youtube-dl update internally
  • Translations refreshed
  • Built with Sailfish Application SDK 2.2 (3.1.0.12)

0.6.7-1

  • Update German translation
  • Fix category cover page background

0.6.6-1

  • Improve dark theme support
  • Fix version number on About page
  • Restore logo in various pages
  • Adjust main menu list item size
  • Adjust video list item size
  • Update Swedish translation

0.6.5-1

  • Added youtube-dl update functionality in Settings
  • Added auto-updating youtube-dl, if it is missing
  • Not bundling youtube-dl anymore
  • Fix for light theme cover
  • Compiled using Sailfish Application SDK 2.1 (3.0.3.9)
  • Changelog added

0.6.2-1

  • Fix quota issue (thanks for help, tworaz!)
  • Re-uploaded correct armv7hl build

0.6.1-RC3

  • Compile using Sailfish Application SDK 2.1 EA (3.0.3)
  • Update youtube-dl

0.6.0-RC2

  • Compile fixes
  • Enable youtube-dl lazy extractors
  • Add channel icon to search results for channels
  • Main menu, Categories list, Video list layout fixes
  • About, Translations and License layout fixes
  • About page credits updated

0.6.0-RC1

  • Update youtube-dl to 2019.02.09
  • Fix translations
  • Performance fixes
  • Tons of compile- and project-related fixes

Comments

t0t3u's picture

Can you also include Subscribe option (like uTube has) whitout the need of an YouTube account?

Thank you!

akikk88's picture

Sounds good! :)

direc85's picture

Sailfish SDK 2.1 has been released and the Jolla Store release of YTPlayer is getting closer! Please report all issues as soon as possible! Thanks!

wesbluemarine's picture

I 've created a Pull Request for adding an audio only streaming, do you think is possible?

Thanks

direc85's picture

Actually I tried to implement 1080p support, which doesn't seem to be possible at the moment but I can still try a few things, and I stumbled upon audio only streams. It doesn't look complicated at all, so audio only might be way easier than I thought :) I'll check your PR if I can isolate your changes.

direc85's picture

I can have a look at it, but please make the pull request to my repo instead, now it's on tworaz's repo. It gets really difficult to figure out the changes this way...

wesbluemarine's picture

Great app!
With black text ambiences the play/pause button is not visible in the tasks grid.

direc85's picture

Thanks for reporting this!

I had totally forgotten dark ambiences exist, so I have to go through all my apps (:

247's picture

Seems is not working for me as the circle is spinning forever, already deleted and re-installed but it hasn't helped me...

247's picture

Ok it's working now

direc85's picture

I had this issue a few times, too, but I couldn't pinpoint the reason why it did it. How did you get working?

Skillmon's picture

Thank you very much. I have just one request, can you please change the icon back to purple? There is a logic behind the colors and multimedia is purple.

Shervrar's picture

Is this because the SFOS media app is purple, or is there something else that says so? For what it's worth, I like the red. It makes sense as YT is red.

Skillmon's picture

That's a convention from the Harmattan days which was followed at least in the early days of SFOS. If you take a look at the multimedia apps in the store or on OpenRepos many of them are in fact purple, e.g. Unplayer, YTPlayer (except this fork), Daedalus, many of the podcast/radio apps. Following such conventions adds to quick operation of the phone and gives the whole OS a more uniform and coherent look.

direc85's picture

Actually the icon was only partially in SVG format, so I'm considering the old logo for the Store release.

direc85's picture

Thanks for commenting.

This indeed seems to be a trend. If it doesn't turn out hideous - it shouldn't - I'll update the icon color in the next release, which should land in Jolla Store, too.

Skillmon's picture

Thank you very much for your answer (and all the work you're putting into this!). Sorry that it took me this long to finally notice your comments. Again, thank you very much!

carmenfdezb's picture

Thanks for the update, it works perfect now

Shervrar's picture

Going on 'subscriptions' lists the channels I am subscribed to, but selecting 'latest videos' shows some random videos from channels I definitely didn't subscribe to. Any Idea how I can see my subscription feed?

direc85's picture

I *think* it shows the latest uploads in general, not your subscriptions' latest videos. I'll check the API if it provides anything useful...

Shervrar's picture

Not sure how good this would be, but if the API does not provide a way to see subscription videos anymore there is another way: RSS.

Users can export a opml file from https://www.youtube.com/subscription_manager. I guess you could make users be able to import their opml file to show subscriptions?

That would admittedly raise the complexity of the program though.

 

Also, would it be possible to make the app open videos it got as an argument? I was considering just using an external RSS app as a workaround and opening youtube links with harbour-ytplayer, but `harbor-ytplayer https://youtube.com/watch?v=1234567` does not cause the video to open in the app.

akikk88's picture

I restart phone and now works :) thanks man

direc85's picture

Good to hear!

direc85's picture

Strange, I had no issues. I'll check it out tomorrow. I'm away until then.

akikk88's picture

I install again and now app don't open

direc85's picture

Whoops! I uploaded a wrong 0.6.2-1 build for armv7hl by accident, so please uninstall and install it again.

Sorry for the mixup!

akikk88's picture

Ok, thanks

akikk88's picture

1080p playback support?

direc85's picture

This has been on my mind, too. I'll see what I can do, once the current situation gets a bit more stable.

direc85's picture

I have a method for updating youtube-dl automatically, and it is high on my todo list. The quota issue comes first, though...

Pages