Patchmanager 3 Beta

Rating: 
4.86207
Your rating: None Average: 4.9 (29 votes)

Patchmanager 3 public beta

Make sure to unapply patches before upgrade from Patchmanager 2. Installation will fail if any patch is applied.

If you have installed prepatch, please remove it before patchmanager3 installation.

Changes between version 2 and version 3:

  • Not changing original files. Patches applied to fakeroot located at /tmp/patchmanager
  • OS update friendly. Patchmanager3 automatically detects when user start downloading an update and unapplying all patches
  • Patches can be reordered to be applied in correct order. Just drag to left and drop at required position
  • Collect information about possible conflicting patches. Visit patch info page.
  • Automatic check for updates for online catalog patches. Notificaiton will popup if new version of patch will be released

Patchmanager daemon acts like proxy, filtering open calls and decide if application should open original file or fake one.

Useful environment variables:
NO_PM_PRELOAD=1 disables preload plugin from filtering calls
PM_PRELOAD_DEBUG=1 enables additional stderr output for preload plugin

Keep in mind this is beta version and should contain a lot of bugs. However it was tested for a while.

Please report all bugs to: https://talk.maemo.org/showthread.php?t=92935

You can collect patchmanager logs by running:
devel-su journalctl -al _COMM=jolla-settings + _EXE=/usr/sbin/patchmanager + _EXE=/usr/bin/patchmanager-dialog > patchmanager.log

Sources available here: https://github.com/sailfishos-patches/patchmanager/tree/patchmanager3

Translate project: https://www.transifex.com/coderus/patchmanager3

 

Big thanks jakibaki for Prepatch. This was very good idea to create such way for applying patches. You can review my plugin here: https://github.com/sailfishos-patches/patchmanager/blob/patchmanager3/sr...

 

Application versions: 
AttachmentSizeDate
File patchmanager-3.0.57-1.125.1.jolla_.armv7hl.rpm338.18 KB11/01/2019 - 17:31
File patchmanager-3.0.57-1.125.1.jolla_.i486.rpm349.84 KB11/01/2019 - 17:31
Changelog: 

Refactored commandline mode

Comments

Marold's picture

Did anyone had problem that after rebooting device or simply turning off, all patches are gone and entering web catalog is endless loop of spinning animation, then when You reinstall patchmanager patches are magically shown and You can reapply them ? It happend to me few times already and Im getting really annoyed :(

coderus's picture

If you have problems you can grab log using command from description and send to me

csg1976's picture

This is a great app. Thanks to all contributors!

levone1's picture

Thanks - since it was a new install, it was easier to just reset device. I just thought you might have an idea right off...

levone1's picture

coderus (or anyone) - I started with a clean install 3.0.2, and enabled dev options, installed Storeman, and enabled repo, then I made some mistake with installing patches - I can't remember exactly what, I either installed patchmanager without enabling repo, or installed a patch without patchmanager - something like that. Anyway, I realized it after I couldn't get to the web catalog, (perpetual spinner), and I was having trouble applying patches, etc. Since then, I have tried everything to undo it - uninstall patchmanager and all patches, disable all repos, uninstall and reinstall Storeman, etc. Nothing I can do fixes it. I can no longer get any patches to show up in patchmanager screen, or connect to web catalog. How can I totally remove all traces and start over? Thanks

coderus's picture

If you send me a logfile i can try to guys what the problem is happened

DameCENO's picture

Let me give it a try and report

DameCENO's picture

Hi Coderus
I have been a problem with Patchmanager, it sees my SFOS as being 3.0.0.8 while I am on 2.2.0.29, thus the web catalogue won't let me download the right patches for my device, marks them as incompatible, giving me those of 3.0.0.8 to download, those won't apply because of my device version. Have uninstalled Patchmanager altogether, reinstalled it, reinstalled the version 1 and started from there no luck, installed 2 and started from there, still no luck.
I need your help, as I can't use my device without patches, and have reset my device and sdxc card 4 times already, since I have gotten the device working as I wanted, not willing to reset it again.
Please help

coderus's picture

ssu re 2.2.0.29

Markkyboy's picture

Sadly, I am still having problems with my patches not appearing in patchmanager list after installing. I still have to select "Unapply all patches" from the pulley menu to make my patches appear in the list - surely I cannot be the only one having this problem?,
I am not resetting my device any more, it's pointless, I still end up with the same annoying result. Another nail in the coffin for me and Sailfish; *bollocks!* :(

Historyscholar's picture

I have translate  it  into  Chinese .Please check it on your  github .

Historyscholar's picture

Thanks  for  you  work !

dfstorm's picture

Well.. After upgrade to 3.0.0.5: patch list is empty, "load engine" do nothing, about do not show version number and the "setting pull down menu" make the app (setting in that case) crash. I try removing the app, reboot, etc... No luck.

subeditor's picture

Same here, but upgrade itself wasn't the reason - PM works fine for sometime after upgrade.

coderus's picture

email me your log. details are in description.

subeditor's picture

Done. Thanks in advance.

mixmax's picture

I understand what's happen. The problem is not with PM, but with the patch 'Devicelock faith text' : you can enable it, but after restarting, all patches are disabled. Sorry...

mixmax's picture

I am alone in this case ?

mixmax's picture

Hi,

is there a problem with the SFOS update ? It is impossible, since SFOS 3.0.0.5, to enable any patch.

Tks, and regards.

Ingvix's picture

Can I somehow bypass the patchmanager daemon so I can read the original files while patch is enabled? Would make developing patches a lot easier.

coderus's picture

Sure, this is noted in description text :)

Markkyboy's picture

Hi coderus, I built 2 new patches yesterday. When I try to install them, they do not appear in patchmanager list. I made the patches the same way I have made all others, but these 2 do not install. I do not get any errors or notifications, except when I try removing, I get a notification "Patch removed".
I'm going round in circles here, any suggestions for troubleshooting and why do I not get any notification to say "Patch installed"...?
I have tried unapplying/removing all patches, then removing patchmanager and then reinstalling patchmanager and all my patches, all of my patches install and apply except the 2 new ones, also, I still do not get notification to say "Patch installed".....any ideas please?

coderus's picture

I have a lot of ideas, but please give me logfile, so i can look :)

Markkyboy's picture

thanks, what's the best way to post my 'patchmanager.log' file?, I've never had to do this before..?

coderus's picture
Markkyboy's picture

Done!, thank you.

4carlos's picture

0.1.4 Analogclock did not work, but after downgrade to 0.1.2 via webkatalog it runs again. Try it.

Jolla 1, 2.0.29

danfin's picture

since upgrading, patchmanager3 beta does not seem to start up anymore. After a restart it hangs at 'analog clock' patch. If I kill it, it shows zero available patches on web catalog, 'load engine' has no effect either. I run Sailfish 2.0.29. After a restart, again it loads patches and hangs at 'analog clock'. Uninstalling 'analog clock' does not help. Any hints? Thank you!

coderus's picture

Please give me a log

Piece_Maker's picture

I'm getting the same issue as this person, log is here: 

http://termbin.com/wrkt

Running an Xperia X with 2.2.0.29 

 

Pages